[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [liquidwar-user] MacOS X doesn't work at all

From: Christian Mauduit
Subject: Re: [liquidwar-user] MacOS X doesn't work at all
Date: Sat, 06 Nov 2004 11:59:16 +0100
User-agent: Mozilla Thunderbird 0.8 (X11/20040918)

Sebastian Vollmer a écrit :
Hello out there

I worked very hard to get liquid war on MacOS X to work but I failed. First I tried to get allegro 4.0.3 to work, buts wrong, because there is no really mac os x supporting... Then I downloaded Allegro 4.1.16 the installation was easy. But after two hours of work I recognised that it did not completely replaced 4.0.3 so I did it by myself. Recompiled it and installed 4.1.16 again. But I tried to install liquid war again. So I do ./configure and make package_macosx_tgz but it failed with:
gfxmode.c: In function `try_one_mode':
gfxmode.c:169: error: `GFX_MODE_TYPE_FULLSCREEN' undeclared (first use in this function)
gfxmode.c:169: error: (Each undeclared identifier is reported only once
gfxmode.c:169: error: for each function it appears in.)
gfxmode.c:171: error: `GFX_MODE_TYPE_WINDOWED' undeclared (first use in this function) So I use google but there was no result for GFX_MODE_TYPE_FULLSCREEN, so I looked into gfxmode.c but I do not really have an Idea what do. So I hope you can help me. I started to write a howto but I wasn't able to complete it, because I wasn't able to get it work by myself:
huh huh don't panic! I've good reasons to believe you're very close to achieving your Liquid War Mac OS port. My guess is that for "some reason" which is hard for me to tell right now (coming back from 3 weeks vacation and just coming back on earth) the fullscreen/windowed support in Allegro has/is either:
- broken under MacOS/X in the current release
- changed in 4.1.16 which is a WIP so API calls and constants are likely to change

In any case I'll try to prepare you code (LW code, that is) that should solve the problem. Not today but pretty soon I think. This is not very tricky stuff, I just need to read docs and take time (ouch) to type a few lines, but this is no big deal.

BTW, if you can access the CVS source tree on savannah it could be very convenient this way I would simply commit the changes to the CVS repository and you could get the updates right away. If not, I can always send you stuff by e-mail but please check that your mailbox can handle big files.

Have a nice day,


PS: and thanks in advance for the upcoming tutorial 8-)

PPS: 5.6.3 is in fact just ready to be released (fixes joystick stuff AFAIK), available from CVS right now. I suggest we wait until you manage things to work under MacOS/X again (Rib Rdb did it a bunch of time ago, so it somehow proves it's possible) and then I release 5.6.3. If I can recall the only reason I did not upload the binary package he submitted was that it was a "temporary CVS built" and it would have caused problems for people to play with it with non MacOS/X users on network games. Otherwise most of the "hard work" (ie byte endianess hell) is already done. Thanks to both of you for helping me with macOS/X.

Christian Mauduit <address@hidden>     __/\__ ___
                                        \~/ ~/(`_ \   ___                   /_o _\   \ \_/ _ \_            \/      \___/ \__)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]