[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [liquidwar-user] MacOS X doesn't work at all

From: Rib Rdb
Subject: Re: [liquidwar-user] MacOS X doesn't work at all
Date: Fri, 22 Oct 2004 10:30:58 -0700

Last time I tried the native OS X version of Allegro there were visual
problems and I couldn't get the program to launch from finder.  I
don't know if there's a newer version that will work better.  But you
should be able to use the X11 version of allegro.  I don't remember
the name of the target, but the makefile should have an option to
create an application bundle that will launch esd and X11 if they
aren't running before starting liquid war.  If I have time I'll try
the aqua allegro again, but that probably won't be for weeks.

On Fri, 22 Oct 2004 08:48:09 +0200, Sebastian Vollmer
<address@hidden> wrote:
> Hello out there
> I worked very hard to get liquid war on MacOS X to work but I failed.
> First I tried to get allegro 4.0.3 to work, buts wrong, because there
> is no really mac os x supporting...
> Then I downloaded Allegro 4.1.16 the installation was easy. But after
> two hours of work I recognised that it did not completely replaced
> 4.0.3 so I did it by myself. Recompiled
> it and installed 4.1.16 again. But I tried to install liquid war again.
> So I do ./configure and make package_macosx_tgz but it failed with:
> gfxmode.c: In function `try_one_mode':
> gfxmode.c:169: error: `GFX_MODE_TYPE_FULLSCREEN' undeclared (first use
> in this function)
> gfxmode.c:169: error: (Each undeclared identifier is reported only once
> gfxmode.c:169: error: for each function it appears in.)
> gfxmode.c:171: error: `GFX_MODE_TYPE_WINDOWED' undeclared (first use in
> this function)
> So I use google but there was no result for GFX_MODE_TYPE_FULLSCREEN,
> so I looked into gfxmode.c but I do not really have an Idea what do. So
> I hope you can help me.
> I started to write a howto but I wasn't able to complete it, because I
> wasn't able to get it work by myself:
> > How to install Liquid War on MacOS X?
> >
> > First of all the Requirements are:
> > -esound (available on fink)
> > -Developer Tools
> > -Allegro >=4.1.16 (
> >
> > First you have to install Allegro:
> > You have to get the UNSTABLE unix source from
> > If you tried to install the
> > stable one, you have to completely remove it!!! Otherwise you are not
> > able to install it.
> > Then you have to extract it. Go to its directory in a shell and type
> > following commands:
> > chmod +x
> > ./ macosx
> > make
> > sudo make install
> > sudo make install-template
> >
> > Then download Liquid War from
> Thanks for reading it,
> Sebastian Vollmer
> _______________________________________________
> liquidwar-user mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]