[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [liquidwar-user] Custom Resources

From: Christian Mauduit
Subject: Re: [liquidwar-user] Custom Resources
Date: Sun, 26 May 2002 23:00:01 +0200
User-agent: Mutt/1.3.28i


On Sun, May 26, 2002 at 10:06:28AM -0400, Mouse wrote:
> I can't seem to get any of the custom stuff to load?  I have liquid war 
> 5.4.5 for Windows unzipped to "C:\GAMES\LW5" with map, texture, and music 
> dirs in the "C:\GAMES\LW5\CUSTOM" directory.  None of the textures or maps 
> show up when I run "LWWIN", or "LWWIN -map C:\GAMES\LW5\CUSTOM\MAP".  
mmm, well, here I'm just puzzled, just tried it here at home, and it
worked just fine. So get ready for the usual set of boring questions:
1 - what kind of Windows do you have (95,XP,...)
2 - how do you launch the game (command line, explorer...)
3 - what is your filesystem (FAT16, NTFS...)
4 - anything special about your computer? 8-)

> The 
> following lines are found in the log file, so I assume the game is finding 
> the directory correctly:
> Loading custom textures from "custom/texture" - success!
> Loading custom maps from "C:\games\Lw5\custom\map" - success!
In fact these lines seem to prove the directories where _not_ found.
Blame the programmer for it - shame on me - but when no custom stuff is
found it returns OK. In fact, it returns "failed..." when a map /
texture is found but is "incorrect". That's to say if you put a random
.bmp file, the game will refuse it as a map.

When a texture / mapis found, a dot is printed at the end of the line.
For instance my log file under Win98 is:

Loading custom textures from "custom/texture".... - success!
Loading custom maps from "custom/map"... - success!
Loading custom musics from "custom/music". - success!
So one can see 4 custom textures have been loaded (4 dots), 3 custom
maps and one custom music.

> I've scrolled through the entire list of textures and maps in the game, but 
> they're just not there.  The game itself runs fine though.  What am I doing 
> wrong?
Honestly, I can't see anything wrong in what you did. The weirdest
thing being that apparently the datafile (lw.dat) is actually found by
lwwin.exe, whereas custom stuff is not.

However, here's a list of hints:
- try to remove everything and re-install the game completely (but you 
  probably already did this...)
- try and launch the DOS version, see if it behaves the same
- try to extract the game with various unzip programs (unzip32.exe,
- launch it from the explorer, from the command line...
- do you use a localized version of Windows? (German, Russian,
  Spanish...) for the problem might be linked to unicode names

The problem might also an Allegro related problem. The binary you have
uses Allegro 4.0.0 but a 4.0.1 release is available, and it seems to be
a bug-fix release. If nothing helps, I'll send you a binary linked with
Allegro 4.0.1, but you'll have to be patient 8-)

Good luck!


Christian Mauduit

reply via email to

[Prev in Thread] Current Thread [Next in Thread]