[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] bug report: android app caches dns entries. linux flatp

From: Han Boetes
Subject: [Linphone-users] bug report: android app caches dns entries. linux flatpak desktop app does the same.
Date: Sat, 29 Feb 2020 17:46:55 +0100


Our asterisk is available from the outside world also inside via split horizon DNS.

First I connected to the internal IP, which works fine.

Then I tried connecting from the internet and I got no connection. So I checked resolving with a network app and our host is properly resolved by android. I checked the firewall, nothing, I pinged the asterisk host, works.

Then I cleared all config data for linphone and then I got a connection!

For consistency’s sake I also tried the same with the flatpak desktop app I downloaded yesterday and that also used the IP it stored for itself instead of following DNS.

So, long story short, linphone is storing dns entries somewhere and doesn't use the system dns.

Thanks for fixing this problem.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]