[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] Linphone bug

From: Grant Griesel
Subject: Re: [Linphone-users] Linphone bug
Date: Mon, 22 Oct 2018 20:53:16 +0200

Hi Stuart,

Thanks so much for your reply.
I will be honest, much of what you said required a google but I think I have understood.

> Have you tried switching services?  
>>> I have switched to Skype through my PC and I am able to make calls without trouble. I have also used a different VOIP system called Keyyo through an old Macbook using the same internet connection without trouble.

> Can you use an echo-test service?
>>> I can use one and have done so without a problem.

>the intermittent nature of your problem screams to me "NAT firewall
>>> I went into my router and found "NAT virtual server set up". There was a server set up under the name Whatsapp... I removed this and disabled NAT and I will run a few tests making calls tomorrow to see if there is any success.
In addition I checked the settings on Linphone and within the "settings" menu under "network settings" there are four options at the bottom of the menu page;
'direct connection to the internet'
'Behind NAT/Firewall (specify gateway IP)'
' Behind NAT/Firewall(use STUN to resolve)'
' Behind NAT/Firewall(use ICE)'

Currently " 'direct connection to the internet' is selected and I have not changed this. Should I change it?

> You just have to swear off IPv4 just like you have to delete your Facebook
>>>In the same "network settings" section mentioned above there is an option to tick "Allow IPv6". In the spirit of a process of elimination I will not select this option until I have tested the effect of changing the router, but it will be my next port of call. 

Thanks again in advance for you help, as well as the sage wisdom about deleting Facebook. 
Kind regards Grant Griesel.

On Mon, 22 Oct 2018 at 19:24, Stuart D. Gathman <address@hidden> wrote:
On Mon, 22 Oct 2018, Grant Griesel wrote:

> I have done the basic troubleshooting of switching  microphone and
> headphones(I'm fairly confident this is not the problem as I use the same
> headphones and microphone on my backup system, Skype, without trouble), as
> well as resetting my router and computer.
> If anyone is able to help it would be greatly appreciated and I would be
> happy to provide other information such as context and screenshots.

Have you tried switching services?  Can you use an echo-test service?
(There are various free ones, probably has one, I know does if you register.)

Also, the intermittent nature of your problem screams to me "NAT firewall
issue".  Personally, I use linphone in peer to peer mode with Cjdns.
All those NAT issue are so last century.  You just have to swear off
IPv4 just like you have to delete your facebook.  It's ok to use IPv4 as a
switching matrix to connect to IPv6 or IPv6 mesh networks (like Cjdns).

              Stuart D. Gathman <address@hidden>
"Confutatis maledictis, flamis acribus addictis" - background song for
a Microsoft sponsored "Where do you want to go from here?" commercial._______________________________________________
Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]