[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] bctoolbox building errors

From: Simon MORLAT
Subject: Re: [Linphone-users] bctoolbox building errors
Date: Wed, 29 Jun 2016 15:11:05 +0200

Hi Petr,

Thanks for reporting this issue while compiling with mbedtls 2.x.
I pushed a fix on git:

commit 719cde84995bb427e458f049113322d0e42cee3b
Author: Simon Morlat <address@hidden>
Date:   Wed Jun 29 15:09:44 2016 +0200

    fix configure script for mbedtls version

Best regards,


2016-06-29 14:25 GMT+02:00 Petr Hanousek <address@hidden>:
Dear developers,
I've currently tried to build bctoolbox (todays version from git) and
have some bugreport here:

1) using ./configure mechanism
While I don't have any polarssl in system and use only mbedtls (debian
testing), I've encountered a configure error:
configure:17162: checking for mbedtls/ssl.h
configure:17162: result: yes
configure:17165: checking for mbedtls_pk_parse_key in -lmbedtls
configure:17190: gcc -o conftest -g -O2  -g  -I/usr/local  conftest.c
-lmbedtls   -L/usr/local/lib >&5
/usr/bin/ld: /tmp/ccgyJ5Tf.o: undefined reference to symbol
//usr/lib/x86_64-linux-gnu/ error adding symbols: DSO
missing from command line
collect2: error: ld returned 1 exit status

Solved with "export LIBS=-lmbedcrypto".

- But the configure script does not correctly craft the Makefiles
regarding polarssl/mbedtls. The make after configure produces an error:

/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
-I..  -I../include -I../src -I/usr/local   -I/usr/local -g -O2  -g
-pthread -D_REENTRANT -MT crypto/polarssl1.2.lo -MD -MP -MF $depbase.Tpo
-c -o crypto/polarssl1.2.lo crypto/polarssl1.2.c &&\
mv -f $depbase.Tpo $depbase.Plo
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../src
-I/usr/local -I/usr/local -g -O2 -g -pthread -D_REENTRANT -MT
crypto/polarssl1.2.lo -MD -MP -MF crypto/.deps/polarssl1.2.Tpo -c
crypto/polarssl1.2.c  -fPIC -DPIC -o crypto/.libs/polarssl1.2.o
crypto/polarssl1.2.c:28:26: fatal error: polarssl/ssl.h: No such file or
compilation terminated.
Makefile:557: recipe for target 'crypto/polarssl1.2.lo' failed
make[2]: *** [crypto/polarssl1.2.lo] Error 1
make[2]: Leaving directory

When I comment all "polarssl" lines in src/Makefile and uncomment all
"mbedtls" lines, the compilation goes OK.

2) using cmake
- Requires CUnit version 3 and higher, while there is AFAIK only version
2.1. I'd expect a note in documentation about that with proper link, if
exists. Or should I use NUnit instead?

I've "solved" this issue with turning off all test abilities of bctoolbox.


   Petr Hanousek                   e-mail: address@hidden
   User Support                    phone:  +420 950 072 112
   CESNET z.s.p.o.                 mobile: +420 606 665 139
   location: Zikova 4, Praha       room: 90a
                        Czech Republic

Linphone-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]