[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Re: Bluetooth Headphones (Steven Blatchford)

From: Kertesz Laszlo
Subject: [Linphone-users] Re: Bluetooth Headphones (Steven Blatchford)
Date: Sat, 11 Dec 2010 19:32:48 +0200
User-agent: Opera Mail/11.00 (Linux)

On Sat, 11 Dec 2010 19:01:23 +0200, <address@hidden> wrote:

Send Linphone-users mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Linphone-users digest..."

Today's Topics:

   1.  Bluetooth Headphones (Steven Blatchford)


Message: 1
Date: Fri, 10 Dec 2010 19:14:10 -0500
From: Steven Blatchford <address@hidden>
Subject: [Linphone-users] Bluetooth Headphones
To: address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain; charset=utf-8


I am not able to get linphone to work with a pair of bluetooth
headphones.  Have others had any luck?  I've read ml archives where
Drago had success with Pulseaudio.

I used bluetooth headsets with PulseAudio. It worked out of the box.
I have Debian Squeeze 32-bit with Gnome installed. I installed PulseAudio (minimum version 9.15 is needed) and enabled it by putting the following in the ~/.asoundrc file :

pcm.!default plug:pulse

pcm.pulse {
   type pulse

Then restarted alsa, pulseaudio.
I installed blueman for bluetooth device management (i did not like the default Gnome tool), turned bluetooth handsfree on, and connected it as a sound device. It appeared in PulseAudio's device list and i routed both outgoing sound and capture to/from it. Then any application that used either ALSA or PulseAudio was routed through the bluetooth device. Used it with Skype, Linphone, Sip Communicator, Sflphone.

After installing and configuring the above stuff, a logout/login or reboot is recommended to make sure the settings stick.

I have been testing with the GUI (linphone-3) using these versions:
v4l-utils 0.8.1
linphone 3.3.2
bluez 4.80
alsa-lib 1.0.23
alsa-utils 1.0.23

Adding 'alsadev=pcm.bluetooth' to $HOME/.linphonerc allows me to hear
the ring when I call my IP.  I am testing on my LAN.  The other test
computer is using a wired headphone and mic running slightly older
versions of the above packages.  I tested the second computer with a
third computer using wired headphone and mic and linphone worked.

Any hints would be appreciated.

Use PulseAudio.
I could not make to use bluetooth over ALSA. I did get some static (and sometimes the output worked, but only from mplayer was clear), but nothing more. With PulseAudio it just worked. The newer PulseAudio (9.21 now) is working very well, it had most of its bugs eliminated.



Linphone-users mailing list

End of Linphone-users Digest, Vol 97, Issue 14

Have a nice day,

Kertesz Laszlo

Using Opera's revolutionary email client:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]