[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-users] Compiling linphone 3.2.1 on Debian Lenny - intermittent

From: address@hidden
Subject: [Linphone-users] Compiling linphone 3.2.1 on Debian Lenny - intermittent audio
Date: Tue, 9 Feb 2010 18:59:01 +0100

Hi All, hi Simon, thanks for your help.

I'm trying to compile linphone 3.2.1 over the embedded-oriented 'Voyage' 
distro, version 0.6.2, which is based on Debian Lenny.
Basically is a Lenny with custom kernels for various boards, for example mine 
is an Alix 3d3.

Since I was running linphone from the Lenny debian packages, I've first deleted 
them, hope I've done it well:
apt-get remove libexosip2-4 liblinphone2 libmediastreamer0 libortp7 
libosip2-3deb linphone-common --purge

Then I've compiled libosip2-3.3.0 and libeXosip2-3.3.0

Then I've added the dir '/usr/local/lib' to /etc/ and run 'ldconfig'.

linphone-3.2.1 compiles fine but outgoing audio is very intermittent, more 
silence than voice.
The microphone works well.
I've tried the alaw and ulaw codecs, with and without transcoding from Asterisk.

The configure string for linphone was:
./configure --prefix=/opt/linphone --enable-gtk_ui=no --enable-video=no

The previous version of linphone worked fine, on the same setup and environment.

Any hint ?

Thanks for supporting,
have a nice day.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]