[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] linphone : call to, rings but doesnt h

From: hd99
Subject: [Linphone-developers] linphone : call to, rings but doesnt hang up
Date: Wed, 18 Oct 2023 02:13:03 +0200 (CEST)


i have tried with a friend recently, im unsure if it's the proper place to talk about it, but it's one of the rare forums with a category focused about SIP/VoIP.

here it is :
gigaset c530ip, i guess it's among the most solt model from the last decade, from that manufacturer.
on frenchy telcos forums, several nerds also have it, so i guess that device is pretty well know. What is highly less known, is the voip network offered by the manufacturer. I was thinking it was running about xmpp protocol. Looks like it's sip only. Well, it started like :

1. i tried to see if it was usable, alive, for a several yrs old device. So i looked into the phone's system, and saw a kind of directory, really difficult to use nowadays, regarding our smartphone's new features : it's both slow and limited in entry's public directory. well, half-public : browse it requires to get a gigaset voip professional phone.

2. when i discovered that "worldwide" directory, i tried to "call" like that, registred accounts. Uh: all were busy/unactive, no one seems available. From family-like accounts, to SMB or others usages, hundred of "sip account" are still registred, and listed.

3. well, after few months of little investigation, with a friend whom gets a such similar phone, we tried to see if it was a out of order network, or just a dormant one with thousand of forgotten accounts. we were then surprised to see that the network was working well, able to get a (unsecured) sip/voip communication.

4. thus, device looks like to get released in retail too early to support s/zrtp. however, even if between both same models, from two different cities, with two different internet access, the communication was working, but from another type of phone/service, it's not at all : i tried from both linphone/ippi software/services. Each time, the gigaset rings, shows the incoming call alert, but even when pushing the green button to hang up, isnt able to start a new communication : it's blocked on the gigast device, while the other (not gigaset, linphone) phone says its entered in communication, with no sound at all, for a while (about a minute) before the communication gets stopped.

qusetion is : how could it be fixed? anyone get success to call a sip gigaset device on network, with a working communication?

here are various logs we went about to retrieve from a friends (from linphone app or device's base with tcpdump) are here :

i thank you vm for your help !

reply via email to

[Prev in Thread] Current Thread [Next in Thread]