[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] [SOLVED] Re: Linux SDK build error: fatal error: Q

From: john
Subject: [Linphone-developers] [SOLVED] Re: Linux SDK build error: fatal error: QQuickFramebufferObject: No such file or directory
Date: Tue, 19 Apr 2022 11:16:42 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.7.0

Answering my own (and Praveen's) question...

I used an environment variable to set the path to the Qt libraries.  In my case this worked:

export Qt5_DIR="/home/my_user_dir/Qt/5.15.2/gcc_64/lib/cmake"

On 4/19/22 10:56, john wrote:


I now have the same problem that Parveen had:

I have done various updates to my system since it worked for me so clearly something changed to break things for me.

Any assistance would appreciated.

Here is the error in build:

[ 76%] Built target mediastreamer
[ 77%] Building CXX object src/CMakeFiles/msqogl.dir/videofilters/msqogl.cpp.o
In file included from /usr/local/src/linphone-sdk/mediastreamer2/src/videofilters/msqogl.cpp:25:
/usr/local/src/linphone-sdk/mediastreamer2/src/videofilters/msqogl.h:23:10: fatal error: QQuickFram
ebufferObject: No such file or directory
  23 | #include <QQuickFramebufferObject>
     |          ^~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
gmake[8]: *** [src/CMakeFiles/msqogl.dir/build.make:76: src/CMakeFiles/msqogl.dir/videofilters/msqo
gl.cpp.o] Error 1
gmake[7]: *** [CMakeFiles/Makefile2:354: src/CMakeFiles/msqogl.dir/all] Error 2
gmake[6]: *** [Makefile:136: all] Error 2
gmake[5]: *** [CMakeFiles/EP_ms2.dir/build.make:88: /usr/local/src/linphone-sdk/build/WORK/desktop/
Stamp/EP_ms2/EP_ms2-build] Error 2
gmake[4]: *** [CMakeFiles/Makefile2:956: CMakeFiles/EP_ms2.dir/all] Error 2
gmake[3]: *** [Makefile:91: all] Error 2
gmake[2]: *** [CMakeFiles/sdk.dir/build.make:88: sdk-prefix/src/sdk-stamp/sdk-build] Error 2
gmake[1]: *** [CMakeFiles/Makefile2:83: CMakeFiles/sdk.dir/all] Error 2
gmake: *** [Makefile:91: all] Error 2

Here is the most recent commit for linphone-SDK I am using:

commit dba6beba015f8012b0a99eb77db81354234936f6 (HEAD -> master, origin/master, origin/HEAD)
Author: Mickaël Turnel <>
Date:   Wed Sep 29 10:15:00 2021 +0200

I am using Fedora 35.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]