[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] RTP Stream Bug via VPN

From: Benny Puder
Subject: Re: [Linphone-developers] RTP Stream Bug via VPN
Date: Fri, 14 Aug 2020 16:39:33 +0200

Hello developers,

I would like to submit a bug with new log files and a little different behavior again. Recently I was told to try it again with version 4.2.2 because a lot of bugs are said to be fixed.

The behavior is that it rings on both sides but closes the call when the counterpart takes the call. The setup is again the same. Connection via VPN into the company network with Ubuntu 18.04.

This is not always reproducible. It's really strange. After this test I restarted Linphone and tried it again. And it worked. So I also attached the log file of Linphone (with "_working" suffix). The other files (wireshark, ip a output, netstat output) are captured in case of the bug. Do you have any idea about that?

Our company SIP server is a Lancom router. I look forward to hearing from you. Thank you!

Kind regards

Please see the following archive for more details:

Am Do., 26. März 2020 um 16:57 Uhr schrieb Benny Puder <>:
Dear developers,

I'm part of a small company and would like to use linphone from the home office via VPN. The SIP registration works well but when the call is established, I don't hear anything from the counterpart. There is also no indication on the little icons that speech is transmitted. So I started to do some investigations.

I'm currently working on Ubuntu 18.04 and installed Linphone 4.1.1 from the flatpak repository as you described on the internet site. The VPN tunnel works fine. My ip configuration can be viewed in the attached file linphone-ipa.log. My computer has the VPN IP address and the local address for the internet connection.

The SIP gateway ( is located in the company network. This route is working properly and my pc can ping other pcs in the company and vice versa. I'm registering with username "16". No password is required.

I also attached the linphone log and a wireshark capture of the tunnel. There you can see that the session was established and the counterpart is sending RTP packets to the port 26935. This should be the right port as you can see in the INVITE message.

I had a short look on the netstat command and saw that linphone didn't listen on this port. But shouldn't it? I also attached the output of the netstat command before the call and during the call.

I also used linphone from my companies computer (also Ubuntu 18.04) and it worked well. I would guess that there is something wrong in conjunction with the VPN network. Or do I need to apply a special configuration? STUN/TURN/ICE related settings are still off or empty.

I also tried to use my android phone with VPN and linphone and it worked nearly fine. It was really important to switch on that all calls were redirected to the gateway. There are sometimes lost connections but maybe they have other reasons which are not related to linphone. This occurs very rarely.

Here are my settings on the computer. I only added the SIP account. I didn't change other settings.

Thank you for your time.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]