[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] linphone-daemon not responding to sound card c

From: Iain Mott
Subject: Re: [Linphone-developers] linphone-daemon not responding to sound card config
Date: Wed, 1 Apr 2020 11:51:17 -0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.4.1

Could someone please let me know if linphone-daemon implements sound device selection as is the case with the linphone desktop app? And if so, is there something wrong with the audio configurations that I listed below? I was unable to find a text file with the stored preferences for linphone 4.1.1 so I'm using the format of the .linphonerc created by linphone 3.6.1.



Em 31/03/2020 11:17, Iain Mott escreveu:
Dear developers,

I am using linphone-daemon to make calls and transfers on a Linux machine running Asterisk. It is important that I use Jack for the audio. With Linphone 4.1.1, this works without problems and the PulseAudio Jack sink/source are delectable in the preferences. I have not however managed to use linphone-daemon with jack.

I start the daemon with:

linphone-daemon --config ~/.linphonerc

The config file is loaded and the sip device to make and receive calls is registered correctly.

The sound device part of the [sound] configuration however in .linphonerc seems to be being ignored and the audio used is always the internal hardware.

In linphonec, "soundcard list" yields:

0: PulseAudio: Áudio interno Estéreo analógico
1: PulseAudio: Scarlett 18i20 USB Multicanal
2: PulseAudio: Jack sink (PulseAudio JACK Sink)
3: PulseAudio: Jack source (PulseAudio JACK Source)
4: ALSA: default
5: ALSA: HDA Intel PCH

So i wish to use device 2 for playback and ringer and device 3 for capture.

I have tried many configurations including:


I've also tried , for the device settings:

playback_dev_id=PulseAudio Jack sink (PulseAudio JACK Sink)
ringer_dev_id=PulseAudio Jack sink (PulseAudio JACK Sink)
capture_dev_id=PulseAudio Jack source (PulseAudio JACK Source)


playback_dev_id=PulseAudio Jack sink
ringer_dev_id=PulseAudio Jack sink
capture_dev_id=PulseAudio Jack source

And further, I've tried various other device combinations but nothing changes. Other changes, such as to the ring tone file, do register correctly.

Can anyone please help?



Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]