[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] Erros compiling bctoolbox

From: Miguel Romaní
Subject: [Linphone-developers] Erros compiling bctoolbox
Date: Thu, 9 Feb 2017 19:15:33 +0100


I'm trying to compile libinphone on odroid c1 Ubuntu Ubuntu 16.04.1 LTS (GNU/Linux 3.10.104-171 armv7l) but always get an error compiling bctoolbox.

First I tried cloning liblinphone, bctoolbox, etc... from github and compiling one by one, but I always get the same error.

Then I tried getting linphone-desktop (which seems to include liblinphone) from with the same results:

$ make --debug

[ 12%] Performing configure step for 'EP_bctoolbox'
loading initial cache file /home/odroid/linphone-desktop/WORK/desktop//tmp/EP_bctoolbox/EP_bctoolbox-cache-Debug.cmake
fatal: ambiguous argument '0.5.0..HEAD': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
-- Using mbedTLS
-- DTLS SRTP available
-- Configuring done
-- Generating done
-- Build files have been written to: /home/odroid/linphone-desktop/WORK/desktop/Build/bctoolbox

and at the end of the trace:

Configuring for target 'x86-linux-gcc'
  enabling x86
  enabling pic
  enabling runtime_cpu_detect
  using yasm
  enabling use_x86inc
  enabling postproc
Unable to invoke compiler: /usr/bin/cc    -m32 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
Configuration failed. This could reflect a misconfiguration of your
toolchains, improper options selected, or another problem. If you
don't see any useful error messages above, the next step is to look
at the configure error log file (config.log) to determine what
configure was trying to do when it died.
CMakeFiles/EP_vpx.dir/build.make:106: recipe for target '/home/odroid/linphone-desktop/WORK/desktop/Stamp/EP_vpx/EP_vpx-configure' failed
make[3]: *** [/home/odroid/linphone-desktop/WORK/desktop/Stamp/EP_vpx/EP_vpx-configure] Error 1
make[3]: Leaving directory '/home/odroid/linphone-desktop/WORK/desktop/cmake'
CMakeFiles/Makefile2:1314: recipe for target 'CMakeFiles/EP_vpx.dir/all' failed
make[2]: *** [CMakeFiles/EP_vpx.dir/all] Error 2
make[2]: Leaving directory '/home/odroid/linphone-desktop/WORK/desktop/cmake'
Makefile:83: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/home/odroid/linphone-desktop/WORK/desktop/cmake'
Makefile:14: recipe for target 'desktop-build' failed
make: *** [desktop-build] Error 2

the first error about bctoolbox seems to be a syntax error invoking gti and the messages at the end of the trace looks like a wrong configuration as it is trying to make  for x86 while odroid has a different architecture.

Any ideas ?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]