[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Linphone-developers Digest, Vol 148, Issue 19

From: William Hutchison
Subject: Re: [Linphone-developers] Linphone-developers Digest, Vol 148, Issue 19
Date: Tue, 16 Jun 2015 16:31:44 -0600

RE Thread: linphone-android not building:

Member Konstantin suggested a fix to me that had worked for him, and it worked for me: simply create symlinks to the aapt and the other required tools.  That almost seems necessary, since the build file is looking in "/linphone-android/${aapt}" for that tool, and of course the tool itself won't be there. It might be helpful to add this to the Readme instructions (or a better fix, assuming there is one) for Linux lightweights like me. Anyway, it built smoothly after that fix. 
    Bill Hutchison

On Sun, Jun 14, 2015 at 10:00 AM, <address@hidden> wrote:
Send Linphone-developers mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Linphone-developers digest..."

Today's Topics:

   1. Followup RE: Problem building Linphone from       sources
      (William Hutchison)


Message: 1
Date: Sat, 13 Jun 2015 11:18:02 -0600
From: William Hutchison <address@hidden>
To: address@hidden
Subject: [Linphone-developers] Followup RE: Problem building Linphone
        from    sources
Content-Type: text/plain; charset="utf-8"

   Sorry for not responding in the same thread, but I don't see how to do
that. The digest instructions and the information on your site for
developers only says how to submit questions, as far as I could find. Can
you point me to how to respond in a thread?

   I finally figured out that the problem was that I had previously done
the git clone into Windows to try building using minGW, but that didn't
work. I just copied those files to Linux, knowing it might not work, but I
assumed the compiler would give me an error about the files, not to say the
file didn't exist. But git cloning directly in Linux fixed the problem.
Sorry for the trouble!

Now I can run make in the top linphone-android directory. It starts fine,
but hits:

Buildfile: /home/whutchi/linphone-android/build.xml
No sub-builds to iterate on
/home/whutchi/android-sdks/tools/ant/build.xml:649: The following error
occurred while executing this line:
/home/whutchi/android-sdks/tools/ant/build.xml:694: Execute failed: Cannot run program
/home/whutchi/linphone-android/${aapt}": error=2, No such file or directory

I see that line 694 is the last line of this block constructing the aapt:
           <aapt executable="${aapt}"


The top-level README and other guides I've seen don't say that the
submodules have to be manually built in advance, but I decided to try
building the submodules separately. Following the instructions I built the
submodules belle-sip and linphone successfully. But I still get the same
error message when I try "make" at the top level. What do I need to do?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>


Linphone-developers mailing list

End of Linphone-developers Digest, Vol 148, Issue 19

reply via email to

[Prev in Thread] Current Thread [Next in Thread]