[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Register Problems linphonecsh

From: Josef Lenz
Subject: Re: [Linphone-developers] Register Problems linphonecsh
Date: Thu, 15 Jan 2015 07:03:46 +0100



did you get any answer yet?


I would like to use the tool linphoncsh shortly.


Thanks for answers.






i am using Linphone 3.7.0 under Windows 8.


When I use linphonec and type „register sip:address@hidden sip: 623“ the client is conected to the account.


On wireshark I can see, that the registration need’s two requests.

In the frist request there is no Authorization in the SIP Message Header.

The answer to request is Status 401 Unauthorized.

In the second request ist he Auhorization in the SIP Message Header.

The answer ist registered.


When I now use linphonecsh (what I need to do) there ist only send one request without Authorization.


I can’t find a way to get registered.


I also tried linphonecsh init –c c:\...\linphonerc to use the settings wich are used by linphone and linphonec. But there is no request to see on wireshark.

This one is because a patch I sent has not yet been reviewed and included for over two years.  shell.c ifdef win32 doesn't parse the command line as it should and uses -c NULL (explicitly for whatever reason) instead.

Search the archives for my name to find the latest patch, which I hope is bug free (I'm not a terribly good C programmer), and if you can, compile Linphone yourself.  Although I haven't had much luck doing so since the 3.7 series because I can't get belle-sip to compile on MinGW.


I also tried linphonecsh init followed by linphonecsh generic „register sip:address@hidden sip: 623“ but there is only send one request without Authorization in the SIP Message Header. The Result is the same :“Status 401 Unauthoized“ .


Thanks for your help





reply via email to

[Prev in Thread] Current Thread [Next in Thread]