[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] [iOS] Issues trying to build current commit

From: Gonzalo Larralde
Subject: [Linphone-developers] [iOS] Issues trying to build current commit
Date: Tue, 24 Jun 2014 15:38:03 -0300

Hi guys, 

I'm trying to build the last commit but I'm getting stuck. It's weird because I was able to build the lib a month ago with the very same setup.

I pulled the changes from origin and updated all the submodules. Everything ran fine, but after getting this error, just in case, tried to redownload the whole repsoitory, so I don't think this is an issue related to an invalid clone. The error remains the same.

This is what I get when the makefile tries to build lib-linphone submodule:

Summary of build options:
* Video support                  true
* GTK interface                  false
* Account assistant              false
* Console interface              false
* Tools                          false
* Message storage                true
* zRTP encryption                false
* uPnP support                   false
* LDAP support                   false
Now type 'make' to compile, and then 'make install' as root to install it.
cd /Users/gonzalo/Desktop/doorbot/otro_linphone/linphone-iphone/submodules/build/../build-i386-apple-darwin/linphone  && export PKG_CONFIG_LIBDIR=/Users/gonzalo/Desktop/doorbot/otro_linphone/linphone-iphone/submodules/build/..//../liblinphone-sdk/i386-apple-darwin/lib/pkgconfig export CONFIG_SITE=/Users/gonzalo/Desktop/doorbot/otro_linphone/linphone-iphone/submodules/build/..//build/ make newdate && make && make install
/Applications/  all-recursive
Making all in build
Making all in macos
make[5]: Nothing to be done for `all'.
make[5]: Nothing to be done for `all-am'.
Making all in m4
make[4]: Nothing to be done for `all'.
Making all in pixmaps
make[4]: Nothing to be done for `all'.
Making all in po
make[4]: Nothing to be done for `all'.
Making all in oRTP
make[4]: *** No rule to make target `all'.  Stop.
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [build-linphone] Error 2
make: *** [broadcast_all] Error 2

It doesn't seem to be able to generate a valid Makefile target for lib-linphone. When make was trying to configure linphone, this came up:

checking for LIBSOUP... no
checking libudev.h usability... no
checking libudev.h presence... no
checking for libudev.h... no
checking for udev_new in -ludev... no
grep: /Users/gonzalo/Desktop/doorbot/otro_linphone/linphone-iphone/submodules/build/..//linphone/oRTP/ No such file or directory
grep: /Users/gonzalo/Desktop/doorbot/otro_linphone/linphone-iphone/submodules/build/..//linphone/mediastreamer2/ No such file or directory
checking for SQLITE3... no
checking for sqlite3_open in -lsqlite3... yes
checking for BELLESIP... yes
checking for sgmltools... no

Not sure if it may be related or not. Of course I'm attaching a longer log. At line 269, the script starts to compile lib-linphone.

I've tried to make the submodules with the following parameters:

make all enable_gpl_third_parties=no enable_zrtp=no

(which is the one we intend to use for the final build)

make all enable_gpl_third_parties=yes enable_zrtp=no

make all

All of them giving the same result. The only thing that changed from the last time I've built it (a month ~ a month and a half ago) is that I installed Xcode 6 beta 1. But I validated that the correct Xcode version was selected

$ xcode-select --print-path

Thanks for your time!


Gonzalo Larralde.

Attachment: linphone-partial-log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]