[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Fwd: linphone file Android

From: David Packer
Subject: Re: [Linphone-developers] Fwd: linphone file Android
Date: Tue, 6 May 2014 16:00:54 +0300

You can use Cygwin or Ubuntu on a VM.

2014-05-06 15:39 GMT+03:00 Amira Elsayed Ismail <address@hidden>:

I'm new using linphone and using Android NDK

I have the following problem, I have downloaded the git repository of linphone and what I want to do is to build it,

I'm using windows cmd to do that using the following command :

D:\aelsayed\Android_SDK_and_NDK\ndk\android-ndk-r9b>bash ndk-build D:/aelsayed/a

but I'm always have the following error :

Android NDK: Your APP_BUILD_SCRIPT points to an unknown file: D:\aelsayed\Androi
k:171: *** Android NDK: Aborting...    .  Stop.

I have the following configuration

in Makefile :

NDK_PATH=$(shell dirnameĀ D:/aelsayed/Android_SDK_and_NDK/ndk/android-ndk-r9b) SDK_PATH=$(shell dirnameĀ D:/aelsayed/Android_SDK_and_NDK/sdk/tools) SDK_PLATFORM_TOOLS_PATH=$(shell dirnameĀ D:/aelsayed/Android_SDK_and_NDK/sdk/platform-tools)

in :

APP_PROJECT_PATH := 'C:/cygwin/home/ActelMe/D;C:/cygwin/aelsayed/android-work/linphone-android;


B.N: I have used cygwin to get application path and it is not working and also when I use the absolute path without using cygwin I have the same error

B.N. I have tried also to create jni folder in the path of ndk and it works but it failed to run the submodules

Please any one can help in this error, or tell me what if the problem

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]