[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] Got error when try to run ./configure for belle-si

From: fess
Subject: [Linphone-developers] Got error when try to run ./configure for belle-sip package on Os x
Date: Wed, 4 Sep 2013 11:19:33 -0700 (PDT)


I got the error, before I compiled successfully old version but bella-sip
caused me to stuck. last 6 hours I try to find the problem. I installed
antlr3 and run version:

bash-3.2# java org.antlr.Tool -version
ANTLR Parser Generator  Version 3.4

I took antlr3 full code from Linphone site but failed to build it.

I have put all headers (antlr3.h, ...) under:


but without success.

Still get the same error, sounds like Linphone (belle-sip) doesn't see thes

>From row 73:

# Checks for libraries.

# Checks for header files.
AC_ARG_WITH( antlr,
      [  --with-antlr      Set prefix where libantlr3c can be found (ex:/usr
or /usr/local)[default=PREFIX] ],
      [ antlr_prefix=${withval}],[ antlr_prefix=${prefix} ])

if test "$antlr_prefix" != "NONE" ; then

I see that it looks for under /opt/local/   but I have there headers

I tried to run it with antlr flag like:

./configure --prefix=/opt/local/ --with-antlr=/opt/local/include/

but get the same error 

What should I do?

Snippets of ./configure log:

checking how to hardcode library paths into programs... immediate
checking antlr3.h usability... no
checking antlr3.h presence... no
checking for antlr3.h... no
checking whether antlr3StringStreamNew is declared... no
checking whether res_ndestroy is declared... yes
configure: error: Could not find antlr3 development files. Please install
antlr3 version > 3.2 (libantlr3c-dev on debian/ubuntu systems)

Really strange

View this message in context:
Sent from the linphone-developers mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]