[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Spanish translation

From: Genghis Khan
Subject: Re: [Linphone-developers] Spanish translation
Date: Tue, 19 Feb 2013 09:10:38 +0100


You are welcome! I am glad I was helpful at some part.

This is not a translation of GTK+, so you probably browsed at wrong

* I assume you will find the relevant file under ../linphone/ directory.
* Do not look for anything under ../bin/ directory, I think.

I guess you need to (re)name the MO file to

Look up where a file is presented somewhere
under ../locale/es/LC_MESSAGES/ and replace that with yours.

Switch at: Options/Preferences/User Interface/Language/es: Spanish

On Mon, 18 Feb 2013 17:17:38 +0100
Álvaro Serrano <address@hidden> wrote:

> Hello and thanks for the answer! 
> It appears you were correct and the file format wasn't encoding the
> characters as UTF-8 by default. I have used another application to
> edit it and now I can build the app using the new file without
> getting any errors. Attached is the new file which should work fine.
> Let me know if there are any issues.
> However I still cannot make my app display the new language. I tried
> your instructions:
> > Compile your .po to .mo separately with this command:
> > $ msgfmt FILE.po
> > 
> > Look up for a directory where the Spanish .mo file is located at
> > your system (after LinPhone is installed) and replace it with yours.
> I used that command and my es.po file to create a Spanish
> file:
> $ sudo msgfmt es.po
> I then copied it over to the bundled app, in
> Contents/Resources/share/locale/es
> However when I try to run it the language is still English. I figured
> the issue may be occurring only in the bundled app and perhaps the
> local installation would work, so I copied and replaced the
> one in opt/local/share/locale/es
> When I run the locally installed app I get the following message in
> terminal:
> $ /opt/local/bin/linphone ; exit;
> ** Message: Found lang es
> (process:87978): Gtk-WARNING **: Locale not supported by C library.
> Using the fallback 'C' locale.
> And the displayed language is then English, of course. 
> One more thing: I have noticed that inside opt/local/share/locale/es
> there is another file: I have no idea what this
> file does or how it is generated.
> Any ideas?
> Thanks,
> Álvaro.

Proper English
4 teh lulz...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]