[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] linphone for Android build failed

From: Firman
Subject: [Linphone-developers] linphone for Android build failed
Date: Wed, 23 Jan 2013 13:16:01 +0800 (SGT)

Hi everybody,

after successfully compiling linphone for iphone (thanks Eli Burke for the help), I now tried to compile linphone for android. But the story is not much different: I got a litany of errors. I made sure that I followed everything the README said. I compiled on Ubuntu 12.10 with NDK r8 and Android SDK r21. 

At first the following was the error that I got:

cd /home/firman/Documents/codes/lin-android/linphone-android/submodules/externals/libvpx && \
./configure --target=armv7-android-gcc --sdk-path=/home/switchlab/Documents/bin/android-ndk --enable-error-concealment && \
make asm_com_offsets.asm \
|| ( echo "VP8 prepare stage failed." ; exit 1 )
Configuring selected codecs
  enabling vp8_encoder
  enabling vp8_decoder
Configuring for target 'armv7-android-gcc'
  enabling armv7
  enabling armv6
  enabling armv5te
  enabling fast_unaligned
  enabling realtime_only
Toolchain is unable to link executables

I then checked the config.err file inside libvpx directory and there are plenty of this error:

BEGIN /tmp/vpx-conf-6312-3247.c
    1 int main(void) {return 0;}
END /tmp/vpx-conf-6312-3247.c
/home/firman/Documents/bin/android-ndk/toolchains/arm-linux-androideabi-4.4.3/prebuilt/linux-x86/bin/arm-linux-androideabi-gcc --sysroot=/home/firman/Documents/bin/android-ndk/platforms/android-14/arch-arm -c -o /tmp/vpx-conf-6312-17726.o /tmp/vpx-conf-6312-3247.c
Assembler messages:
Fatal error: invalid -march= option: `armv5te'

I tried to delete all lines containing the string armv5te inside the libvpx directory but the error persisted. Anyone experiencing the same issue? Any hints would be highly appreciated. 

Thanks and regards,
Arek Malang

reply via email to

[Prev in Thread] Current Thread [Next in Thread]