[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] linphone - iphone compiling steps

From: Jehan Monnier
Subject: Re: [Linphone-developers] linphone - iphone compiling steps
Date: Mon, 2 Jan 2012 12:16:39 +0100

Thanks for your very detailed report.
I don't have this issue on my macbook running Lion with nawk 20110810.
For now, I keep the REAME unchanged. In case some else meet this issue, he will found the solution from your report.

Best regards

Le 30 déc. 2011 à 17:45, Jiang Jinke a écrit :

I finally managed to compile the linphone-iphone project's submodules.
Here is how I do.

Since the mac has two awk, one is the /usr/bin/awk, and other is the /opt/.../bin/nawk
I found that if I install the nawk, it's rather annoying. Even I do an port upgrade will fail with the same nawk: illegal jump type 339.
We are experiencing problem on the nawk, so why not disable the nawk and just use the awk.
So I remove the nawk from macports.
It seems the macport for Lion, nawk 20110810 has problem even on building it's own port such as the automake and other ports.
Just do:
sudo port uinstall nawk.

In linphone-iphone README file said you need to install nawk, but infact you should not install this, or you will fail to build the submodules and get the illegal jump type 339 error as we do.
Linphone for iPhone depends on liblinphone sdk. To build this sdk, you must install both xcode with iPhone OS SDK  and MacPorts ( with the following ports:

linphone-iphone README should add some notice about this issue on Mac OS X Lion.

there are many reported conflict on macports' nawk,

Samford Jiang

On Thu, Dec 22, 2011 at 6:34 PM, Jiang Jinke <address@hidden> wrote:

I found a reported bug in nawk, but I don't know whethe it cause this problem, check

I found the problem reported exist in osip/configure script in a line like

     line = substr(line, 1, len) "" value "" substr(line, len + keylen + 3)

comment out this line, will have the config.h compile fail, then reported error in configure
     /^[\t ]*#[\t ]*(define|undef)[\t ]+$ac_word_re([\t (]|\$)/ {

I tried to install the old version of nawk but failed with a newest version
sudo port uninstall nawk
sudo port install nawk @20100523_0

Jinke Jiang

On Thu, Dec 22, 2011 at 5:12 PM, Jiang Jinke <address@hidden> wrote:
Hi Vasif,
I had exactly the same error as yours. I'm using Mac OS Lion 10.7.2, macport Version: 2.0.3 with the latest packages.

checking for struct timeval... yes

configure: creating ./config.status
config.status: creating libosip2.pc
nawk: illegal jump type 339
 input record number 1, file
 source line number 151

config.status: error: could not create libosip2.pc

Jinke Jiang

On Wed, Dec 14, 2011 at 11:03 PM, Vasif N <address@hidden> wrote:
Hi all;

I am trying to compile latest linphone code for iPhone.
Following the read me file.
When I am trying to make all, it does all it execution and fails at a point giving the error below:
configure: creating ./config.status
config.status: creating libosip2.pc
nawk: illegal statement
source line number 3
config.status: error: could not create libosip2.pc
make[1]: *** [/Users/vnagarwala/linphone-iphone/submodules/build/../build-armv6-apple-darwin/externals/osip/Makefile] Error 1
make: *** [build] Error 2
This is what I have done up-till now.
-Installed the macport .dmg for lion from macport site.
-Then sudo install all the required macports listed in read me file.
- did couple of more stuff given in read me
and then make all...... fails

Can anybody help me with the steps, is there anything that I am missing?

Any help appreciated... Thanks in advance...


Linphone-developers mailing list

Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]