[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] problem with oRTP library

From: Alexander Venin
Subject: [Linphone-developers] problem with oRTP library
Date: Wed, 03 Mar 2010 10:53:20 +0300

Hello All.
I have problem with oRTP library (from linphone-3.2.1). I try run samples 
(mrtprecv.c, mrtpsend.c) in "oRTP\src\tests\" directory, but there is no file 
transfer between them.
I run these samples with next arguments:
mrtprecv bin 5060 1
mrtpsend <filename> 5060 1
Both samples run at the same PC (Windows XP SP3), and mrtprecv creates file 
bin0000.dat with zero size. I try to run these samples on different PC and have 
the same result.
But when I build the mediastremer2 library under Mandrake Linux these samples 
works perfectly.
When I run server part (mrtprecv sample) on Windows PC ( there is no firewall 
or antivirus installed) and client (mrtpsend) part on Linux - no file transfer 
Then I begin debug all network communications with wireshark network protocol 
analyzer. So, I see that all rtp packets from host with mrtpsend successfully 
arrived to destination host where mrtprecv is running. Then I start debug 
inside the library+ and found one strange thing: function recvfrom in mrtprecv 
sample (called from: rtp2disk->rtp_session_recv_with_ts-> 
rtp_session_recvm_with_ts-> rtp_session_rtp_recv) return -1 and errnum = 
WSAEWOULDBLOCK (no data is queued to be read from the socket). Why it's 
happening I can't understand.
Could any one share some working samples of file transfer using oRTP library ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]