[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] odd behaviours with linphone 3.1.2

From: Jim Diamond
Subject: [Linphone-developers] odd behaviours with linphone 3.1.2
Date: Fri, 31 Jul 2009 15:45:03 -0300
User-agent: Mutt/1.5.18 (2008-05-17)

If anyone can shed some light on these issues, I would appreciate it.

(0) Initially I could not convince Linphone to properly connect with
another connection which is behind a Linksys WRT54G router, even
though that system's router is set (with port triggering) to open
ports 5060 to 9079.  (The trigger is based on another program I had
running at the time, and, as far as I can tell, it seems to open all
the requested ports.)  Linphone would, however, connect to a linphone
on a system which is directly connected to the internet.

I tried connecting both with "Behind NAT / Firewall" (and giving the
external IP address) and "Behind NAT / Fireway (use STUN to resolve)".
I tried connecting from both ends.

In the cases where it would not connect properly, it knew the call was
connected, but I could not receive video or audio.

But when I configured the local router for port triggering, things
started to work.  Shouldn't STUN be able to deal with punching holes
through the firewall/router?

(1) Once I got things running, Linphone kept dropping the connection
today, it rarely stayed connected more than 1 minute.  I didn't notice
any other problems with anything else I was doing at the time, but
perhaps nothing else was as sensitive to network conditions.  I am
wildly speculating that very short momentary packet losses causes
Linphone to disconnect.  Is that speculation correct?

If my speculation is correct, is there some way to tell Linphone to be
a bit more patient, should the packets not get through for some
relatively small time?

(2) In some situation(s) which I can't pin down, linphone-3 gets
confused about what it should be showing the video window.  Earlier
today I was trying to use linphone and it somehow got confused about
what it is doing.  The other end disconnected from the internet hours
ago, but at my end
- the control window has a button saying "start call", not :terminate
  call", but
- the video window has the small "picture-in-picture" window as well as
  the larger webcam image
  - the picture-in-picture image is showing my webcam image about 95% of
    the time, but keeps flicking to and from the "No webcam" picture
  - the main picture shows a frame from the video hours ago about 95%
    of the time, and the rest of the time it quickly flashes up
    another image, which I believe is another frame from the video call.

I did a "netstat -an" before and after stopping linphone when it was
in this latter confused state.  Here is the diff of before and after

< udp        0      0     
< udp        0      0     
< udp        0    436  *
< udp        0      0  *
< udp        0      0  *
< udp        0      0  *
< udp        0      0  *
< udp        0      0      
< udp        0      0  *
< udp        0      0  *
< udp        0      0  *
< udp        0      0  *
< udp        0      0      
< unix  3      [ ]         STREAM     CONNECTED     56550    /tmp/.X11-unix/X0
< unix  3      [ ]         STREAM     CONNECTED     56549
< unix  366    [ ]         STREAM     CONNECTED     56548    /tmp/.X11-unix/X0
< unix  3      [ ]         STREAM     CONNECTED     56547
< unix  3      [ ]         STREAM     CONNECTED     56435    /tmp/.X11-unix/X0
< unix  3      [ ]         STREAM     CONNECTED     56434

Can anyone suggest why, hours after the other end went away, it
(apparently) had four established connections to the IP I was
connected to?

(And when I say "the other end went away", I mean the other computer
was shut down and turned off.)

Thanks for any insight that can be offered.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]