[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] No sound in video call

From: Conrad Beckert
Subject: Re: [Linphone-developers] No sound in video call
Date: Fri, 12 Oct 2007 19:54:28 +0200

Dear Simon, Hallo Andreas

> I stumbled across similar problems some weeks ago.
> Audio/Video-call between linphonec 1.7.1 and Eyebeam 1.5 (WinXP), direct 
> IP calling in the LAN, so no NAT or whatever in between.
Well - I forgot to mention that I also tried to call directly (before
the documented test- still on edgy) - same results as Andreas has.

> Sometimes there was no outgoing audio (no audio rtp packets sent), 
> incoming audio was perfect. Outgoing video was ok, no incoming video 
> stream (intentionally none provided by peer).
> Terminating the call and reestablish a new call to the same peer without 
> any change several times lead to a functional connection from time to 
> time.
Indeed - trying again and again sometimes results in a successful
connection. But it is not predictable.

> I could see no pattern beside that without video it worked always irrc. 
> Also the bandwidth limits had some influence iirc.
Interesting point - I  always suspected (and you make me more certain)
the issue has to do with the GSM codec. 

I remember having seen some message like "GSM (codec?) cannot (can't??)
be used" - obviously its not on the log this time. What a pity - 

When bandwidth is set to "reasonable" values - such as 192kb/sec upload
- there is not enough room for video and G.711 audio - so I suppose some
other audio codec is taken. The other end has Speex disabled as well as
Asterisk. So GSM is left.

This would explain the working connection in audio only calls - they
simply switch to G711. 

My setup is: 
- endpoint 2002 connected to Asterisk server on the open Internet (no
NAT - firewall big wide open.) 
- endpoint 3101 connected to the same Asterisk - same firewall settings,
same registration - but behind NAT. (and this is Linphone-Windows)

As long as 3101 calls 2002 everything works - but not the other way
'round. (this is a step ahead - hopefully - as before the upgrade to
feisty I had trouble this way either)

> Switching from soundcard to file playback always worked.
What did you do here? Did you tried the command line version of linphone
(forgot its name - linphonec??) - to what avail?

> Just wanted to throw in a "something seems to be not perfect".
> I had no time so far to dig deeper, but I definitivly will, as I need to 
> get this stable. I'll be glad to help tracking this down, but most 
> probably not before end of November.
Anyway - if there is something I can do to help - please let me know.

Have a nice weekend

reply via email to

[Prev in Thread] Current Thread [Next in Thread]