[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: partcombine & killCues

From: Aaron Hill
Subject: Re: partcombine & killCues
Date: Fri, 24 Jan 2020 04:41:29 -0800
User-agent: Roundcube Webmail/1.3.8

On 2020-01-24 3:03 am, David Kastrup wrote:
Aaron Hill <address@hidden> writes:
If you do this enough, putting it in a music function will make your
score much more readable:

cueName = #(define-music-function (parser location name) (markup?)
  #{ \tag #'cueName \set CueVoice.instrumentCueName = #name #})

% . . .

In recent 2.19, this should work as

cueName = \tag #'cueName \set CueVoice.instrumentCueName = \etc

and in those versions you can at least leave off the "parser location"

\cueDuring #"bassoon" #DOWN { \cueName "Bsn." R1 }

My bad, I forgot to include the \version statement in the snippet. OP had used 2.18, so I wanted my snippet to be compatible with 2.18 as well, hence the inclusion of parser and location.

Otherwise, the 2.19 syntax is so much nicer.  \etc is quite magical.  (:

-- Aaron Hill

reply via email to

[Prev in Thread] Current Thread [Next in Thread]