[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can Guile v3.0.8 be part of the LilyPond v2.24 release?

From: Volodymyr Prokopyuk
Subject: Re: Can Guile v3.0.8 be part of the LilyPond v2.24 release?
Date: Tue, 15 Nov 2022 10:37:57 +0100

Hi Jean,

It worked like a charm! Thank you very much!

Maybe it makes sense to put a line in the installation instructions
about ../configure
GUILE_FLAVOR=guile-3.0 for those who have Guile 3.0 and build the latest
LilyPond from source, if it is not already there.

Thank you,

On Tue, Nov 15, 2022 at 7:56 AM Jean Abou Samra <> wrote:

> Le 14/11/2022 à 18:31, Volodymyr Prokopyuk a écrit :
> > Hi,
> >
> > It seems that LilyPond v2.23.81 depends on Guile v2.2.
> >
> > On Linux Arch systems (e. g. Manjaro) Guile v3.0.8 is installed by
> default.
> >
> > Currently LilyPond v2.23.81 requires Guile v2.2 as a mandatory
> dependency,
> > which makes installation of the latest Lilypond versions from source
> > problematic on Linux Arch systems.
> >
> > How difficult the migration from Guile v2.2 to Guile v3.0.8 is for
> > LilyPond? Can the migration be part of the LilyPond v2.24 release?
> This is already possible:
> ../configure GUILE_FLAVOR=guile-3.0
> I use Guile 3.0 on a daily basis for development (because
> byte-compilation is faster).
> You can use this for youself, but if you are a package
> maintainer, very please think really hard before packaging
> LilyPond with Guile 3.0. Everyone else will have Guile 2.2,
> so it might make for code that works for someone not work
> for someone else. (We display the Guile version on startup
> these days, but Frescobaldi removes this message, unfortunately.)
> It has also not been tested widely as Guile 2.2 has been.
> Thanks,
> Jean

reply via email to

[Prev in Thread] Current Thread [Next in Thread]