[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.21.3 build problem on Mac OS X Mojave

From: Jonas Hahnfeld
Subject: Re: 2.21.3 build problem on Mac OS X Mojave
Date: Sat, 18 Jul 2020 15:35:55 +0200
User-agent: Evolution 3.36.4


Am Samstag, den 18.07.2020, 15:14 +0200 schrieb Jacques Menu:
> Hello folks,
> I’m trying to build LilyPond 2.21.3 locally, both on Debian 9 and Mac OS X 
> 10.14.6 (Mojave). 
> On the latter, I installed Apple’s XCode, the needed tools in /opt with 
> MacPorts, and the needed fonts in /opt/local/share/fonts/urw-core35-fonts. 
> Performing the same ‘git clone’ and the same steps alongside, I run into a 
> situation in which the contents of the build directory is by far different on 
> both OSes, see below.
> Then ‘make' runs fine on Debian, but fails on Mojave due to a missing 
> build/make directory.
> That beats me. Can someone explain why ‘../configure’ creates fewer files on 
> the Mac OS X side? The trace it produces is at the end of this message.
> [...]
> menu@macbookprojm: ~/lilypond-git/build > ../configure 
> --with-urwotf-dir=/opt/local/share/fonts/urw-core35-fonts
> [...]
> configure: creating ./config.status
> config.status: creating config.make
> config.status: creating config.hh
> config.status: config.hh is unchanged

This looks as if the build directory was not empty. Could it be that
the directory still contained stale results from a previous invocation
of configure? If that failed, I'm not sure if configure correctly
recovers in all cases...
It's of course possible that this is the result of executing configure
again to obtain a log after the failures described before. In that
case, creating a new build directory won't help much and maybe you
already tried...


Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]