[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: outlet v. context

From: Dan Eble
Subject: Re: outlet v. context
Date: Sat, 4 Jul 2020 11:27:39 -0400

On Jul 4, 2020, at 11:15, David Kastrup <> wrote:
> While you are at it: I don't see that there is lots of sense in having
> get_context () for some classes and context () for others.  Or
> get_parent_context () for some and get_daddy_context () for others.
> Generally the get_ prefix seems a bit spurious: given that we use the
> naming convention field_ for data members, calling the read accessor
> field () seems like it should always be workable.

Ugh.  I'm working on the outlet/context change now (involving lots of rebasing 
of my work in progress).  I'll probably be unwilling to do more than that 
immediately, but regardless, I should let others weigh in on get_foo() v. foo() 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]