lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Improve relocation debug messages. (issue 347070043 by address@hidde


From: lemzwerg
Subject: Re: Improve relocation debug messages. (issue 347070043 by address@hidden)
Date: Fri, 08 Feb 2019 01:49:58 -0800

Reviewers: dak,

Message:
On 2019/02/08 09:42:27, dak wrote:
https://codereview.appspot.com/347070043/diff/1/lily/relocate.cc
File lily/relocate.cc (right):


https://codereview.appspot.com/347070043/diff/1/lily/relocate.cc#newcode128
lily/relocate.cc:128: TOPLEVEL_VERSION, package_datadir));
Why no .c_str () here (and lots of other places)?

Why should it?  It works without `c_str'.  Am I missing something?

Description:
Improve relocation debug messages.

This patch contains the following commits.

* relocate.cc: Don't use double forward slashes in file names.

* main.cc, relocate.cc: Improve relocation debug messages.

  This commit does the following.

  * Add `_f ()' where necessary.
  * Improve readability of code by omitting some `.c_str ()'
conversions.
  * Synchronize formatting of messages.
  * Improve messages to make the more readable.  Also add some new ones.
  * Indent all messages related to relocation.

* relocate.cc: Add `indent' parameter to `sane_putenv'.

  We are going to use that to provide better formatting of debug
messages.

Please review this at https://codereview.appspot.com/347070043/

Affected files (+67, -38 lines):
  M lily/include/relocate.hh
  M lily/main.cc
  M lily/relocate.cc





reply via email to

[Prev in Thread] Current Thread [Next in Thread]