[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libunwind-devel] build error on Linux x86

From: Mario Emmenlauer
Subject: Re: [Libunwind-devel] build error on Linux x86
Date: Mon, 13 Mar 2017 17:10:30 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.7.0

Dear Dave,

On 13.03.2017 16:38, Dave Watson wrote:
> On 03/12/17 10:26 PM, Mario Emmenlauer wrote:
>> I'm trying to build libunwind as a prerequisite to another library
>> on different flavors of Linux. It works on all x86_64 platforms I've
>> tried, but fails on Ubuntu 16.04 x86 (gcc 5.4) with below error.
>> I guess I'm doing something wrong or missing a dependency, can you
>> please help? I've tried libunwind 1.2-rc1 and 1.2.
>> PS: on a completely unrelated note, the website mentions 1.1 as the
>> latest download, but 1.2 is available from the download folder.
> Thanks, I'll update the website shortly.
>> This is the error I get:
>> [...]
>> In file included from ./elf32.h:7:0,
>>                  from ../include/tdep-x86/libunwind_i.h:35,
>>                  from ../include/tdep/libunwind_i.h:23,
>>                  from ../include/libunwind_i.h:344,
>>                  from elfxx.h:33,
>>                  from elf64.h:7,
>>                  from elf64.c:2:
>> ./elfxx.h:70:1: note: previous definition of 'elf_map_image' was here
>>  elf_map_image (struct elf_image *ei, const char *path)
>>  ^
> It looks like it is pulling in both tdep-x86/libunwind_i.h *and*
> tdep-x86_64/libunwind_i.h (and hence both elf32.h and elf64.h), but
> it's not clear to me why. Possible include path issue?  Are
> libunwind-devel headers already installed on your ubuntu machine?

Thanks for the quick reply! libunwind and -devel are not installed,
but I do override some environment variables, in case that might be
related? I set:
because this helped to build on some flavours of Linux, and I set:
because my installations go into THIRDPARTYTARGETDIR. There should
not be any x86_64 libs in THIRDPARTYTARGETDIR since I build on a
dedicated i386 docker image. Could the environment variables some-
how confuse configure, or is the -U_FORTIFY_SOURCE maybe the root
of the problem?

Here is my call to configure:
    ./configure \
        --prefix="$THIRDPARTYTARGETDIR/unwind" \
        --with-pic \
        --disable-static \

All the best,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]