libunwind-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Libunwind-devel] [PATCH 08/19] Rename `backtrace' to `do_backtrace' in


From: Tommi Rantala
Subject: [Libunwind-devel] [PATCH 08/19] Rename `backtrace' to `do_backtrace' in tests/Gtest-init.cxx
Date: Wed, 5 Sep 2012 14:50:16 +0300

Rename `backtrace' to `do_backtrace' in tests/Gtest-init.cxx for sanity;
the `backtrace' name is already defined in various other places.
---
 tests/Gtest-init.cxx |    8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/tests/Gtest-init.cxx b/tests/Gtest-init.cxx
index 18f1463..d238a08 100644
--- a/tests/Gtest-init.cxx
+++ b/tests/Gtest-init.cxx
@@ -45,7 +45,7 @@ class Test_Class {
 static Test_Class t;
 
 static void
-backtrace (void)
+do_backtrace (void)
 {
   char name[128], off[32];
   unw_word_t ip, offset;
@@ -78,14 +78,14 @@ backtrace (void)
 static void
 b (void)
 {
-  backtrace();
+  do_backtrace();
 }
 
 static void
 a (void)
 {
   if (verbose)
-    printf ("backtrace() from atexit()-handler:\n");
+    printf ("do_backtrace() from atexit()-handler:\n");
   b();
   if (errors)
     abort ();  /* cannot portably call exit() from an atexit() handler */
@@ -94,7 +94,7 @@ a (void)
 Test_Class::Test_Class (void)
 {
   if (verbose)
-    printf ("backtrace() from constructor:\n");
+    printf ("do_backtrace() from constructor:\n");
   b();
 }
 
-- 
1.7.9.5




reply via email to

[Prev in Thread] Current Thread [Next in Thread]