libtool-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Supporting 'ld' --as-needed


From: Szombathelyi Gyrgy
Subject: Supporting 'ld' --as-needed
Date: Sat, 5 Jun 2004 20:16:26 +0200
User-agent: KMail/1.6.52

____________________________________________________________________
Miert fizetsz az internetert? Korlatlan, ingyenes internet hozzaferes a 
FreeStarttol.
Probald ki most! http://www.freestart.hu

Hello!

A week ago I posted a patch to address@hidden which allows to use the 
--as-needed flag which is implemented in newer GNU 'ld's. This flag prevents 
linking unneeded dependencies into the target program/lib. The patch just 
puts $compiler_flags before any dependencies, so specifiing 
'LDFLAGS=-Wl,--as-needed' will actually work.
Can this patch accepted?

Regards,
György

Attachment: lt.diff.gz
Description: GNU Zip compressed data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]