libtool-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[SCM] GNU Libtool branch, libtool-next, created. v2.4-19-g85b2fd6


From: Gary V. Vaughan
Subject: [SCM] GNU Libtool branch, libtool-next, created. v2.4-19-g85b2fd6
Date: Fri, 24 Sep 2010 19:01:18 +0000

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "GNU Libtool".

The branch, libtool-next has been created
        at  85b2fd6395897f6bd68da8f35f80d4167772c7db (commit)

- Log -----------------------------------------------------------------
commit 85b2fd6395897f6bd68da8f35f80d4167772c7db
Author: Gary V. Vaughan <address@hidden>
Date:   Fri Sep 24 21:12:18 2010 +0700

    maint: use macro_dir consistently in all files.
    
    * Makefile.am: Replace all uses of m4dir with macrodir to
    match AC_CONFIG_MACRO_DIR.
    * libltdl/config/libtoolize.m4sh: Replace all uses of macrodir
    with macro_dir.
    * tests/defs.m4sh, tests/sh.test: Likewise.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit 862ac4b6648d7c4dee6b6d6edc09176969b27f2b
Author: Gary V. Vaughan <address@hidden>
Date:   Fri Sep 24 21:10:19 2010 +0700

    maint: use aux_dir consistently in all files.
    
    * Makefile.am, Makefile.maint: Replace all uses of auxdir
    with aux_dir to match AC_CONFIG_AUX_DIR.
    * libltdl/config/libtoolize.m4sh: Likewise.
    * tests/defs.m4sh, tests/getopt-m4sh.at: Likewise.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit af74d5861725980febc025e4b01b67730324c030
Author: Gary V. Vaughan <address@hidden>
Date:   Fri Sep 24 20:58:39 2010 +0700

    Makefile: try to be robust against shell meta-chars in filenames.
    
    * Makefile.am: In each rule body, unless a make variable needs
    to be seen as multiple words by the shell (for word-splitting
    loops, or because it contains several commands), quote it. Use
    single quotes unless the shell needs to perform variable inter-
    polation, in which case use double quotes.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit 3674fa1b60aa9de19376f02f48337426306bf5e8
Author: Gary V. Vaughan <address@hidden>
Date:   Fri Sep 24 20:26:36 2010 +0700

    maint: let make employ user's `SED' setting.
    
    * Makefile.am: Replace hard-coded `sed' with `$(SED)' through-
    out.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit 9813c6d8e4ef726f84cdef67b8fe61381d0f3e39
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 2 16:44:32 2010 +0700

    maint: simplify and improve safety of bootstrap process.
    
    * Makefile.am (bootstrap_files): List files that need to be
    generated at bootstrap time before `./configure && make' can
    work.  It turns out that this is considerably fewer files than we
    had thought necessary previously.
    (bootstrap-deps-prep): Ensure minimum set of required substitution
    variables are non-empty.
    (bootstrap-deps): Depend on `bootstrap' files.
    * bootstrap (Generate bootstrap dependencies): Now that
    `Makefile.am' is entirely responsible for rebuilding files at
    bootstrap time, we need only specify the new `bootstrap-deps'
    target, and supply values for the substitutions checked by
    `bootstrap-deps-prep'.
    * configure.ac (AC_CONFIG_SRCDIR): `libtoolize.in' is not here yet
    right after running `bootstrap'.  So rely on the presence of
    `libltdl/config/libtoolize.m4sh', which is always there.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit dcf5ff46f3037e8e0364ee7bf9f8a3bd2e6ee7af
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 19:53:48 2010 +0700

    build: eliminate superfluous temporary files from `Makefile.am'.
    
    * Makefile.am (CLEANFILES): Remove temporary file entries.
    (libtoolize.in, libltdl/config/ltmain.sh, libltdl/m4/ltversion.m4)
    (tests/defs, tests/testsuite): Factor away temporary files.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit d6385aabc040792cc6bfcaf7af72f1d130814591
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 19:42:30 2010 +0700

    build: eliminate `ltmain.in' and `libtoolize.in' intermediate files.
    
    * Makefile.am (libltdl/config/ltmain.sh, libtoolize.in): Pipe
    the output of `$(LT_M4SH)' directly into `$(bootstrap_edit)' to
    avoid use of superfluous intermediate file.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit cdeb16ae0f034d210bb0a33b477b04f33f94b00a
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 19:31:10 2010 +0700

    build: don't hardcode repeated long paths in Makefile rules.
    
    According to the DRY principle, scattering several copies of
    something across a file or project leads to pain.  Let's not
    do that!
    * Makefile.am (Makefile_in, Makefile_inc, defs_in, defs_m4sh),
    (libtoolize_in, ltmain_m4sh, ltversion_in): New variables to
    hold the location of important files and targets.
    (EXTRA_DIST): Add the distributed ones by variable.
    (libtoolize, libltdl/Makefile.am, libltdl/m4/ltversion.m4)
    (libltdl/config/ltmain.sh, libltdl/stamp-mk, tests/defs)
    (tests/defs.in): Use the new variables to reduce noise and
    repetition.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit 4f3d14a0ced18d627543949183ae018a01ef2205
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 18:30:36 2010 +0700

    build: make better use of automatic variables in `Makefile.am'.
    
    * Makefile.am (libtoolize, libtoolize.in, libltdl/Makefile.am)
    (libltdl/config/mkstamp, libltdl/config/ltmain.m4sh)
    (libltdl/m4/ltversion.m4, tests/testsuite, tests/defs.in):
    Make better use of automatic variables.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit c8b7bc751ec87d50524004e4b361617786875d8f
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 18:44:16 2010 +0700

    build: name temporary files in `Makefile.am' consistently.
    
    Sadly, we still have to jump through hoops for MICROS~1's very
    old, very broken 8.3 naming convention, so we have to be careful
    to be unique in the first 8 letters, and not to use two periods
    in a filename, otherwise we could use the much more elegent
    `temporary files use "address@hidden"' idiom:
    * Makefile.am (libltdl/m4/ltversion.m4): Rename temporary file
    to `ltversion.tmp'.
    (libltdl/config/ltmain.sh): Rename temporary file to
    `libltdl/config/ltmain.tmp'.
    (libtoolize): Rename temporary file to `libtoolize.tmp'.
    (tests/defs): Rename temporary file to `tests/defs.tmp'
    (tests/testsuite): Rename temporary file to `tests/testsuite.tmp'.
    (CLEANFILES): Append temporary files as we create rules that
    use them.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit 626dfe3d98569b271d8d139c6a200d1f7f3d0aff
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 18:06:09 2010 +0700

    build: factor Makefile.am `m4sh' invocations to LT_M4SH.
    
    * Makefile.am (LT_M4SH): Now that all directories are listed as
    fully qualified paths, the search path argument to M4SH is always
    the same, so factor it out into a variable.  Adjust all callers.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit ed87a34a9f0ec8c52c86534e61ea8f9520524a82
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 18:02:12 2010 +0700

    build: avoid unnecessary directory changes in Makefile rules.
    
    * Makefile.am (doc/notes.txt, libltdl/m4/ltversion.m4,
    (libltdl/config/ltmain.m4sh, libtoolize.in, libltdl/Makefile.am)
    (libltdl/config/mkstamp, tests/testsuite, tests/defs.in): Avoid
    unnecessary `cd' commands by using fully qualified paths to files
    outside of current directory.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit 57d371bcf4a9cb323188ed417b833ced2b59adf0
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 17:37:00 2010 +0700

    build: compare `revision' rather than `correctver' in Makefile.am.
    
    * Makefile.am (rebuild): Set the shell variable `revision' rather
    than `correctver' for clarity of purpose.
    (bootstrap_edit, libltdl/config/ltmain.sh): Adjust.
    (libltdl/m4/ltversion.m4): Likewise, and alse, instead of munging
    the serial number comment line with set, extract `macro_version'
    from this file, and compare it directly with `revision'.
    (libtool): Likewise for `package_revision'.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit a2bb0c980f2b50ab31fedd18bb4890843b3d399a
Author: Gary V. Vaughan <address@hidden>
Date:   Fri Sep 24 12:51:36 2010 +0700

    libtool: remove redundant unsubstituted shell var defaults.
    
    * Makefile.am (libltdl/config/ltmain.sh): Boilerplate code from
    libltdl/config/general.m4 sets some default shell variables
    designed to be substituted by `$(configure_edit)'.  Actually,
    `libtool' uses the language tag values for those variables, and
    `ltmain.m4sh' is not passed through `$(configure_edit)', so they
    are just noise.  Edit them out at bootstrap time.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

commit c9497cc81cc46ce8848452240a323266440c4cb9
Author: Gary V. Vaughan <address@hidden>
Date:   Thu Sep 23 17:00:08 2010 +0700

    maint: don't leak developer GREP, SED etc into distribution file.
    
    * Makefile.am: Having rearranged the file, now apply the actual
    changes to follow-up.
    (edit): Split into two parts...
    (bootstrap_edit): ...substitutions that should happen at bootstrap
    time...
    (configure_edit): ...and substitutions that should not happen until
    configure time.
    * Makefile.am (libltdl/m4/ltversion.m4, libltdl/config/ltmain.sh)
    (libtoolize.in, tests/package.m4): Use bootstrap_edit.
    (libtoolize, tests/defs): Use configure_edit.
    * HACKING (Release Procedure): Remove the note to workaround the
    bug fixed by this changeset.
    * NEWS (Bug fixes): Mention that this bug is now fixed.
    Reported by Joerg Sonnenberger.

commit dd5b4f06557a4c5ec7b06d7814b95ecd63ab63b8
Author: Gary V. Vaughan <address@hidden>
Date:   Wed Sep 1 14:41:52 2010 +0700

    maint: rearrange Makefile.am in preparation for a follow-up patch.
    
    * Makefile.am (Libtool scripts.): Move this section below the
    `Bootstrap.' section...
    (libtoolize.in): ...except this one which is generated at
    bootstrap time, and was added into the `Bootstrap.' section.
    (Libltdl.): Move this section below the `Libtool scripts.'
    section.
    
    Signed-off-by: Gary V. Vaughan <address@hidden>

-----------------------------------------------------------------------


hooks/post-receive
-- 
GNU Libtool



reply via email to

[Prev in Thread] Current Thread [Next in Thread]