[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Target candidate: Thinkpad T400s

From: persmule
Subject: Re: [Libreboot] Target candidate: Thinkpad T400s
Date: Mon, 23 May 2016 21:47:28 +0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.6.0

Hi Bruno,

The graphic problem has been fixed in the newist git.

The clock problem of the last stable release is actually that you cannot
save the correct time when shutting down the linux 4.3 or higher.
Libreboot d48086382951072039226a8cbde1d9d009cfad12 and newer version has
fixed this problem. You can set the correct time manually, and test
whether it can survive after shutdown.

Everything works fine on my x200. Suspension and graphic output for grub
remains failed on my t400s.

All my computer is running Debian GNU/Linux testing, in which linux
4.5.4-1 has resently been updated.

在 2016年05月23日 21:34, Bruno Dantas 写道:
> Hi, persmule. I figured ssh would probably work, but I only have this
> one laptop readily available. Good to know that this worked, though.
> TIMTOWTDI is usually a good thing, especially here.
> Are you booting linux 4.3 or higher? If so, can you please confirm that
> with libreboot d48086382951072039226a8cbde1d9d009cfad12 the year is
> correct after a boot? Also, is suspend working for you?
> Thanks,
> Bruno
> On 05/20/2016 09:49 PM, persmule wrote:
>> Hi Bruno,
>> I have test the newest git and got the same result with yours.
>> Fortunately, the boxes only lack monitors, so I could operate them via ssh.
>> In order to get a usable rom image, I reset my local repo to
>> d48086382951072039226a8cbde1d9d009cfad12, just before
>> 452664f9b5f332469ac2331321ee7548b2812315, Arthur Heymans' "set vram on
>> gm45 to 352M" was commited, and the rom images built from the repo of
>> that time is usable again.
>> 在 2016年05月21日 00:18, Bruno Dantas 写道:
>>> Hello, everybody. Just a heads up:
>>> I have a T400 and decided to try the latest rom (2016-May-20) in the hopes 
>>> that a) suspend works and b) the year is correct after booting with linux 
>>> kernel 4.5.
>>> I was not able to test either, as the latest rom caused my monitor not to 
>>> work at all--nothing but a black screen with a random pattern of pink and 
>>> yellow pixels.  Fortunately, I have a little song that plays when I arrive 
>>> at my desktop, so I could tell that the boot process proceeded normally 
>>> even though I couldn't see anything.
>>> Fortunately, I have a keyboard shortcut to open up a terminal and, by 
>>> piping commands to espeak, I was able to navigate my directory structure 
>>> and re-flash the stable release (20150518). Now all is well again. 

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]