[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] No EEPROM/flash device found

From: Denis 'GNUtoo' Carikli
Subject: Re: [Libreboot] No EEPROM/flash device found
Date: Mon, 16 May 2016 15:35:46 +0200

On Wed, 11 May 2016 21:15:38 +0100
Alex McGrath Kraak <address@hidden> wrote:

> Hello.

> I am currently trying to flash libreboot to a thinkpad x200 from an
> arduino.
Which Arduino? Which Arduino fimrware?
- Not all Arduinos operate at the same voltage.
- Not all Arduinos have the same kind of serial connection:
  - Some use an FTDI chip to do USB<->Serial.
  - Some use a microcontroller with some code in it to do the same
  - Some do it on the main microcontroller, again with some code.
  - Some have serial directly. 

There are also several fimrwares for it:
- Some old fimrwares which I couldn't find the sources of, or which
  weren't free software, I don't remember which one it is.
- serprog-duino, I wrote that one long time ago, but it's now
  deprecated in favor of frser-duino.
- frser-duino, available at

> However i am running into an error when i run the command to
> flash. "No EEPROM/flash device found". i have followed the
> instructions here[] and
> here[] appropriately.
I'm currently offline and I can't check the links right now, sorry.

> I understand that using a beaglebone is reccomended, just i cant
> really spend the extra 50€ at the moment, and i own an arduino, and
> seemingly it is possible to flash libreboot with one.
Arduinos may work, but you need extra caution when using it:
-> Check if the voltage matches, incorrect voltages can break your
   flash chip, and potentially your laptop, immediately, or in the long
-> I had issues with the 8u2 in my code, the new frser-duino probably
   fixes that.
-> You also have the same constraints than with other programmers, that
   is short wires, good connection to the chip and so on.
   The coreboot or flashrom wiki has an article about that. I don't
   remember its name off hand, it's probably something with "wiring"
   in the title, or "connection" or something like that.

> the command i run in order to flash is:
> "sudo flashrom -p serprog:dev=/dev/ttyACM0:115200 -w
> x200_8mb_ukqwerty_vesafb.rom -V "
- Check if /dev/ttyACM0 appears when you plug the Arduino
- Check with the fimrware(frser-duino) instruction if the speed matches
  it. If flashrom sees the firmware, both settings are correct.

Next time, if it doesn't work, post a flashrom log, flashrom has an
option for that:
> -o, --output <logfile>
It will generate a log with a good debug level, independently of the
fact that you use -V or not.


Attachment: pgpCHYLByV1Pl.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]