[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] No EEPROM found using Bus Pirate for flashing X200 (Winb

From: giulio
Subject: Re: [Libreboot] No EEPROM found using Bus Pirate for flashing X200 (Winbond W25X64)
Date: Thu, 12 May 2016 07:19:01 +0000
User-agent: Roundcube Webmail

On 2016-05-07 18:34, Joerg Albert wrote:
On 07.05.2016 11:14, Giulio wrote:
1.(BR) 2.(RD) 3.(OR) 4.(YW) 5.(GN) 6.(BL) 7.(PU) 8.(GR) >9.(WT)
GND 3.3V 5.0V ADC VPU AUX CLK MOSI >CS MISO P P P I I I O O >O I GND 3.29V 4.93V 0.00V 0.00V L L L >H H

Now on the bus pirate both MODE and VREG leds are on.

However if I run

flashrom -p buspirate_spi:dev=/dev/ttyUSB3
flashrom v0.9.9-r1955 on Linux (i686)
flashrom is free software, get the source code at URL: flashrom+org
2. Normal (H=3.3V, L=GND)
Calibrating delay loop... OK.
Bus Pirate firmware 6.1 and older does not support SPI speeds above 2
MHz. Limiting speed to 2 MHz.
It is recommended to upgrade to firmware 6.2 or newer.
No EEPROM/flash device found.
Note: flashrom can never write if the flash chip isn't found

Durin this process, both MODE and VREG leds are turned off and the bus
pirate seems to reset (or at least it exits from the SPI mode).
I'm not too familiar with the Bus Pirate, maybe the 150mA it is rated
for at the 3.3V pin are not enough for your setup.
Have you tried with an external power supply for the 3.3V instead of
the Bus Pirate's internal one?
Can you watch the voltage on  the 3.3V pin while running  flashrom on
an oscilloscope?

The wiring looks fine.


Finally after a lot of attempts i bought new jumper cables and while it still fails with the Bus Pirate, the eeprom is successfully detected using a Raspberry Pi without external power supply.

Thanks for the help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]