[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] No EEPROM/flash device found

From: Joerg Albert
Subject: Re: [Libreboot] No EEPROM/flash device found
Date: Thu, 12 May 2016 00:35:15 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.2

On 11.05.2016 22:15, Alex McGrath Kraak wrote:
> I am currently trying to flash libreboot to a thinkpad x200 from an arduino.
> However i am running into an error when i run the command to flash.
> "No EEPROM/flash device found". i have followed the instructions
> here[] and
> here[] appropriately.
> I understand that using a beaglebone is reccomended, just i cant
> really spend the extra 50€ at the moment, and i own an arduino, and
> seemingly it is possible to flash libreboot with one.
> the command i run in order to flash is:
> "sudo flashrom -p serprog:dev=/dev/ttyACM0:115200 -w
> x200_8mb_ukqwerty_vesafb.rom -V "
Never tried to use flashrom with an Arduino myself, but from the links above:

What kind of level shifter (5V/3.3V) do you use? Or are you using an Arduino 
with 3.3V levels on the pins?
Putting 5V logic level to the SPI flash pins may damage it or the Southbridge.

If you supply Vdd (3.3V) from the Arduino to the SPI flash, try to measure the 
voltage on this wire after connecting
it. You power more devices than the SPI flash in the X200, maybe the voltage 
breaks down.

Before writing a new image I'd always call flashrom without any -w or -r just 
to check
if it detects the chip correctly. Afterwards I usually backup the old content, 
i.e. read it twice or
three times in different files and compare the md5sum of them.`

BTW, flashrom compiles and runs fine under Raspian on a RaspberryPi, where 
older models are quite cheap.
And everything is at 3.3V here.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]