[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] No EEPROM found using Bus Pirate for flashing X200 (Winb

From: Joerg Albert
Subject: Re: [Libreboot] No EEPROM found using Bus Pirate for flashing X200 (Winbond W25X64)
Date: Sat, 7 May 2016 20:34:03 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.2

On 07.05.2016 11:14, Giulio wrote:
> SPI>v
> Pinstates:
> 1.(BR)  2.(RD)  3.(OR)  4.(YW)  5.(GN)  6.(BL)  7.(PU)  8.(GR)  >9.(WT)
>  0.(Blk)
>> GND     3.3V    5.0V    ADC     VPU     AUX     CLK     MOSI    >CS   MISO
>> P       P       P       I       I       I       O       O       >O       I
>> GND     3.29V   4.93V   0.00V   0.00V   L       L       L       >H       H
>> SPI>
> Now on the bus pirate both MODE and VREG leds are on.
> However if I run
>> flashrom -p buspirate_spi:dev=/dev/ttyUSB3
>> flashrom v0.9.9-r1955 on Linux (i686)
>> flashrom is free software, get the source code at URL: flashrom+org
>> 2. Normal (H=3.3V, L=GND)
>> Calibrating delay loop... OK.
>> Bus Pirate firmware 6.1 and older does not support SPI speeds above 2
>> MHz. Limiting speed to 2 MHz.
>> It is recommended to upgrade to firmware 6.2 or newer.
>> No EEPROM/flash device found.
>> Note: flashrom can never write if the flash chip isn't found
>> automatically.Blk)
> Durin this process, both MODE and VREG leds are turned off and the bus
> pirate seems to reset (or at least it exits from the SPI mode).
I'm not too familiar with the Bus Pirate, maybe the 150mA it is rated for at 
the 3.3V pin are not enough for your setup.
Have you tried with an external power supply for the 3.3V instead of the Bus 
Pirate's internal one?
Can you watch the voltage on  the 3.3V pin while running  flashrom on an 

The wiring looks fine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]