[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] flashrom fails with BIOS chip on ThinkPad T400

From: ng0
Subject: Re: [Libreboot] flashrom fails with BIOS chip on ThinkPad T400
Date: Mon, 02 May 2016 11:53:41 +0200

Thomas Umbach <address@hidden> writes:

> Hello Johannes,
> On Mon, 25 Apr 2016 17:42:40 +0200
> Johannes Merkert <address@hidden> wrote:
>> Hash: SHA256
>> Hi,
>> my Name is Johannes Merkert and I am an author for the german computer
>> magazine c't ( I tried to install Libreboot on a ThinkPad T400
>> following the guide on
>> (
>> When I tried to test flashrom with the BIOS chip I got the following
>> error:
>> address@hidden:~# ./flashrom -p
>> linux_spi:dev=/dev/spidev1.0,spispeed=5 12
>> flashrom v0.9.8-unknown on Linux 3.8.13-bone79 (armv7l)
>> flashrom is free software, get the source code at
>> http://www.flashrom.or g
>> Calibrating delay loop... OK.
>> Found Generic flash chip "unknown SPI chip (RDID)" (0 kB, SPI) on
>> linux_spi.
>> ===
>> This flash part has status NOT WORKING for operations: PROBE READ
>> The test status of this chip may have been updated in the latest
>> development
>> version of flashrom. If you are running the latest development
>> version, please email a report to address@hidden if any of the
>> above operations
>> work correctly for you with this flash chip. Please include the
>> flashrom log
>> file for all operations you tested (see the man page for details), and
>> mention
>> which mainboard or programmer you tested in the subject line.
>> Thanks for your help!
>> No operations were specified.
>> Does this mean my T400 uses another flash chip and I can not upgrade
>> it to libreboot?
> Good news: Most likely not.
> This usually happens due to a bad contact, bad or too long cables.
> If you go by the manual, you can't do it wrong. Sometimes it'll work
> when you're just about to give up - don't give up! =)
> Check for
>  * max cable length 10cm or so for all cables (the cables are usually
>    unshielded)

It worked for me so far with BeagleBone Black + 25cm female
cables + male adapters from Conrad Electronics store + Pomona

>  * power: use an external pdu for all pins on the clip and the BBB that
>    need Vcc (I'm using a lab pdu which works well, but any pdu will
>    do)
>  * check if you've made the right connections (the flashing manual is
>    good and doesn't leave anything out at all, but it can be confusing
>    if you don't have experience)
>  * check if the clip has a good contact
>  * try over and over again, perhaps wiggle the cables in between (last
>    time I flashed I needed 20 or so attempts)
> Note: The X200 is far more easy to flash because you only need to
> lift the palm rest and have access to the chip immediately. You'd have
> the same problems flashing if you have a bad setup though. 
> Good luck.
>> Faithfully,
>>   Johannes Merkert

I had a reading problem with the t400 at first too, but it was
resolved when I looked at the chip manual/specs, it was resolved
like this for me, using the BBB's P9 with the SOIC 300-MIL:
Sometimes miso and mosi are switched.
In case of bbb rev c, d0 and d1 on P9 are MOSI/MISO.

For me personally I also had forgotten to connect power (3V pin
on the P9 of BBB) from BBB to the chip, without power no
The BeagleBone Powersource (its own power adapter, not an
external one) worked for me in my case.

I'd recommend to get the chips manual and compare connections, I
only know for T400 with SOIC 300-MIL

♥Ⓐ ng0

reply via email to

[Prev in Thread] Current Thread [Next in Thread]