[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] flashrom fails with BIOS chip on ThinkPad T400

From: Thomas Umbach
Subject: Re: [Libreboot] flashrom fails with BIOS chip on ThinkPad T400
Date: Mon, 25 Apr 2016 17:26:47 +0000

Hello Johannes,

On Mon, 25 Apr 2016 17:42:40 +0200
Johannes Merkert <address@hidden> wrote:

> Hash: SHA256
> Hi,
> my Name is Johannes Merkert and I am an author for the german computer
> magazine c't ( I tried to install Libreboot on a ThinkPad T400
> following the guide on
> (
> When I tried to test flashrom with the BIOS chip I got the following
> error:
> address@hidden:~# ./flashrom -p
> linux_spi:dev=/dev/spidev1.0,spispeed=5 12
> flashrom v0.9.8-unknown on Linux 3.8.13-bone79 (armv7l)
> flashrom is free software, get the source code at
> http://www.flashrom.or g
> Calibrating delay loop... OK.
> Found Generic flash chip "unknown SPI chip (RDID)" (0 kB, SPI) on
> linux_spi.
> ===
> This flash part has status NOT WORKING for operations: PROBE READ
> The test status of this chip may have been updated in the latest
> development
> version of flashrom. If you are running the latest development
> version, please email a report to address@hidden if any of the
> above operations
> work correctly for you with this flash chip. Please include the
> flashrom log
> file for all operations you tested (see the man page for details), and
> mention
> which mainboard or programmer you tested in the subject line.
> Thanks for your help!
> No operations were specified.
> Does this mean my T400 uses another flash chip and I can not upgrade
> it to libreboot?

Good news: Most likely not.

This usually happens due to a bad contact, bad or too long cables.
If you go by the manual, you can't do it wrong. Sometimes it'll work
when you're just about to give up - don't give up! =)

Check for
 * max cable length 10cm or so for all cables (the cables are usually
 * power: use an external pdu for all pins on the clip and the BBB that
   need Vcc (I'm using a lab pdu which works well, but any pdu will
 * check if you've made the right connections (the flashing manual is
   good and doesn't leave anything out at all, but it can be confusing
   if you don't have experience)
 * check if the clip has a good contact
 * try over and over again, perhaps wiggle the cables in between (last
   time I flashed I needed 20 or so attempts)

Note: The X200 is far more easy to flash because you only need to
lift the palm rest and have access to the chip immediately. You'd have
the same problems flashing if you have a bad setup though. 

Good luck.

> Faithfully,
>   Johannes Merkert

Best regards/Mit freundlichen Grüßen/Cordialement/Met vriendelijke groet
Thomas Umbach

Follow us on GNUsocial:

Gebroeders Danhieuxstr. 8, 3090 Overijse, Belgium
VATIN BE0641807527

GPG key fingerprint: FD5E 2543 EE62 7395 00A6  9FBB F228 7A48 7CA2 3FA5

  * Non-free software is an injustice. Use GNU/Linux.

  * Consider using Email encryption.

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]