[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Troubles flashing a T500

From: Louis Delmas
Subject: Re: [Libreboot] Troubles flashing a T500
Date: Wed, 6 Apr 2016 18:25:09 +0200


I finally managed to flash the t500.

I case that can help some newcomer in the future. I'm explaining here
how I managed to get it flashed.

As it turned out my PSU was not properly delivering 3.3V, unplugged I
was mesuring 3.37V but once plugged to the macronix chip, the tension
was only 2.85V.

So what I did was to use port 3 of the beaglebone to power the chip
during flashing. It turns out the beaglebone is more reliable when it
comes to the stability of tension... But I still continued to use the
ground from the PSU (connected to port 2 of BB).

From there there was some improvement because there was only one bit of
error. But still no "VERIFIED"

So I plugged the WP pin (pin 9 of the chip) to port 4 of the
beaglebone. This is the Write protection pin. If connected to 3.3V this
allows all the chip to be written.

And then I was able to flash the chip in one try at spispeed=512.

To sum up here is the final connection that worked :

===  ethernet jack and VGA port ====
 4 (3.3V BB)     -       - 21
 1               -       - 17
 NC              -       - NC
 NC              -       - NC
 NC              -       - NC
 NC              -       - NC
 18              -       - 3 (3.3V from BB)
 22              -       - NC - this is pin 1 on the flash chip
===  SATA port ===

And port 2 of the BB connected to the ground (PSU for example).

Hoping that may help future newcomers that face similar problem and
find no information online.


Le Sun, 3 Apr 2016 13:12:44 +0200,
Louis Delmas <address@hidden> a écrit :

> Hi,
> I have been trying for numerous times to flash a T500 without success,
> I describe here my setup and what I already tried, if some of you have
> ideas I would be glad to try them because I am getting annoyed with
> this chip that refuses to get flashed ...
> My setup :
> -I use the setup proposed in the Libreboot documentation (BBB + PSU)
> -I tried flashrom included in libreboot_utils and also compiled it
> from git.
> -My cables are short (10cm) and coax+twisted (a link is proposed on
> Libreboot documentation)
> -this setup was able to flash on first try a Winbond "W25X64" on a
> x200 -this setup is able to get reproducible reads at spispeed=256,
> 512 and 1024 . For some reason that does not work with 128...
> The system I want to flash
> -T500 with a Macronix "MX25L6405D"
> -The thinkpad bios was password locked but as flashing erases all the
> chip I thought this would not be a problem.
> What I've tried so far
> -"Basic" flash as described in the Libreboot Doc (spispeed 256, 512,
> 1024) numerous times (close to 20 times for each speed)
> -Connecting pin 1 and 9 of the chip to 3.3V (I found the libreboot doc
> is not very clear on that subject) I looked at the MX24L6405D
> factsheet to understand a little bit more. As I understand the need
> to connect WP to 3.3V I don't understand the role of HOLD in that
> case.
> All of this does not work and I get **always** the same error
> message : "Erase/write done.
> Verifying flash... FAILED at 0x00000000! Expected=0x08,
> Found=0x5a, ..." failed byte count changes every time.
> I feel I've exhausted all the possible ideas of improvements now and
> I'm starting to get annoyed by this... If somebody can help that
> would be great....
> cheers
> Louis

GPG Public key rsa4096/0x1D567BC42DF1E1EA
Fingerprint = 9EE9 F130 F7AE 076D D63B 5AF8 1D56 7BC4 2DF1 E1EA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]