[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Libreboot] X60T correctly flashed/unbrick, LCD probably compatible but

From: Garreau\, Alexandre
Subject: [Libreboot] X60T correctly flashed/unbrick, LCD probably compatible but black screen
Date: Sat, 12 Dec 2015 17:07:39 +0100
User-agent: Gnus (5.13), GNU Emacs 24.5.1 (i586-pc-linux-gnu)


I have jumper cables, a RaspBerry Pi, a pomona 5250, a multimeter,
pincers, lot of good screwdrivers, soldering iron, metal drill, etc.
I unbricked/reflashed successfully an X60T, Libreboot and GRUB can boot
and even beep, but the screen stays black/switched off (yet the leds are
on and I can switch it on by the screen button), and that’s not the
“unsupported LCD blank screen” issue because I get the same problem of
black screen reflashing factory.bin (the original lenovo BIOS I dumped
before to try to flash for the first time, internally, and get a brick)
and even the “factory.bin” dumped from another X60T.

I’ve prior to this mail searched help on IRC (#libreboot, #flashrom and
#coreboot) in order to progress in my understanding of this issue, yet
it persists:

I recently (well, not so much now) bought an X60T with a lenovo bios
(since mine was broken, most of time not booting anymore, just showing a
black screen), then, of course, prior to everything, I dumped the
original content of the flash chip (the lenovo bios) into a file
“factory.bin”, and then tried to flash it internally (log here:
<>). So to get to the next step I halted
and switched on again the computer… and since then, a brick: black
screen, black screen, black screen.

So I purchased a pomona 5250 SOIC-8 Clip from China, it made some months
to arrive, and then I borrowed some jumper cables from a friend and
found an old RaspBerry Pi (no choice, I’m going to order the BeagleBone
Black and maybe one day a bus pirate when I’ll get more money), in order
to try to reflash and unbrick everything materially.

Since at the beginning I didn’t understood how to power on the
motherboard (with the harddisk connector etc.) I even bought a
multimeter in order to check if my pomona clip, my jumper cables, my
RaspBerry Pi pins, the flash chip, etc. work/get powered fine, and
they do.

So after a long time trying to kill a screwed screw with a metal drill
(since soldering nor glue worked) and trying to understand how to power
up the motherboard (I had forgot the harddisk thing) with the AC charger
(since the 3.3V PSU pin of the RaspBerry Pi caused it to stop ethernet
connection to my computer), I finally succeded to flash it.

So the flashing works, it shows « VERIFIED », and dumping it again with
« -r » makes a file with the same sha512sum of the rom I dumped each
time. I tried the x60_frdvbepo_vesafb.rom (that I then modified so it
beeps at boot), the factory.bin and even another factory-newnew.bin
coming from the dump of the lenovo bios of the unflashed X60T I
currently use in replacement (so that’s probably not the “unsupported
LCD blank screen” issue, unless the factory.bin mysteriously doesn’t
work). But the screen stayed black. I got suggested on #libreboot to try
to remove/change position or even replace ram, so I did (in all possible
combinations), and the best I obtained is this thing that instead of
directely powering up and staying like this with black screen, it did
this strange behavior I already noticed before on my old libreboot
computer of powering up fans and all leds, then everything goes off and
after a second the “powered up” led and the fan switch on again. So I
got suggested grub was running but without access to screen, so I
modified the rom to make it beep, and, actually, it beeps. So libreboot
and grub are working, but with black screen.

I attach the three roms and the complete verbose logs of the flash for
each respectively, and each time I flashed with a command of this kind:
“./flashrom -o x60_frdvbepo_vesafb.rom.log -p
linux_spi:dev=/dev/spidev0.0,spispeed=500 -w x60_frdvbepo_vesafb.rom”

Attachment: factory.bin
Description: Binary data

Attachment: factory-newnew.bin
Description: Binary data

Attachment: x60_frdvbepo_vesafb.rom
Description: Binary data

Attachment: factory.bin.log
Description: Binary data

Attachment: factory-new.bin.log
Description: Binary data

Attachment: x60_frdvbepo_vesafb.rom.log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]