[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Problems installing libreboot on C201

From: Albin
Subject: Re: [Libreboot] Problems installing libreboot on C201
Date: Sun, 6 Dec 2015 23:26:30 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.4.0


Den 2015-12-06 kl. 12:46, skrev Paul Kocialkowski:
> Hi,
> Le dimanche 06 décembre 2015 à 12:44 +0100, Albin a écrit :
>> Den 2015-12-06 kl. 10:33, skrev Paul Kocialkowski:
>>> Le samedi 05 décembre 2015 à 15:25 +0100, Albin a écrit :
>>>> Den 2015-12-05 kl. 13:27, skrev Paul Kocialkowski:
>>>>> Le samedi 05 décembre 2015 à 00:34 +0100, Albin a écrit :
>>>>>> I just found another guide
>>>>>> ( that mentions a step
>>>>>> that's missing on besides removing the write-protect
>>>>>> screw one also has to run "flashrom --wp-disable". This should explain
>>>>>> the permissions issue I had.
>>>>> Can you confirm that this is the case (and that you were already using
>>>>> the root account for your first report)? I didn't have to go through
>>>>> this step when flashing, but maybe it is required the first time.
>>>> Yes, I was using the root account for the first report. Now I've also
>>>> tried to run the command "flashrom --wp-disable" which does output
>>>> "SUCCESS". That did NOT help though because, just as before, the command
>>>> "./cros-flash-replace flash.img coreboot ro-frid" results in: "bash:
>>>> ./cros-flash-replace: Permission denied".
>>> Ahh I see, so "Permission denied" is not in all caps (which would have
>>> looked like a flashrom error message). I bet this is shell complaining
>>> because the script isn't executable. Try running:
>>> chmod a+x cros-flash-replace
>>> before running it an everything should work fine. Maybe it would be
>>> worth mentioning on the installation page.
>> I had already checked and tried to modify the permissions before asking
>> on the email list. I get "Permission denied" despite executable
>> permissions (that were already there), even with chmod 777. Isn't that
>> strange?
> Maybe your filesystem doesn't allow execution (mounted with noexec?).
> Perhaps try moving the files to the internal storage of the device
> (instead of an external media that the system might mount with noexec),
> or the opposite.

Problem solved; libreboot installed!

I first inserted the SD card into a different computer and tried to run
the script there but got the same error message. Then I copied over
flash.img into the veyron_speedy directory that was created after the
compilation process and ran the script from there as user. This worked
fine and then I had no trouble installing libreboot on the chromebook
using flashrom.

It would be good to mention in the documentation that there can be a
problem with execution rights. I had the same problem when trying to run
the scrip both from the SD card and from the internal storage, i.e.
after copying over the files from the SD card.

Now I only need to figure out how to install a functional GNU system and
get rid of ChromeOS. Inserting a Debian installer (armhf) and pressing
Ctrl+U results in a loud *beep* even with all the security features
disabled. Do I need to prepare a custom installer image?



>>>>>> Den 2015-12-04 kl. 23:49, skrev Albin:
>>>>>>> Hi.
>>>>>>> Tonight I tried to install libreboot onto an ASOS C201. I ran into a
>>>>>>> number of difficulties that I managed to overcome (see the points below,
>>>>>>> my contribution to the docs), but then I got stuck at the point where
>>>>>>> one is to run the cros-flash-replace script. The terminal keeps
>>>>>>> returning PERMISSION DENIED. The file permissions, however, are the same
>>>>>>> as just after compilation and I've also removed The Screw as instructed.
>>>>>>> Does anyone have a clue what might be the problem?
>>>>>>> Cheers,
>>>>>>> Albin
>>>>>>> Errors found in the documentation:
>>>>>>> 1. There are *eight* screws that need to be removed to open the device,
>>>>>>> not seven. There is (at least on my device) one also beneath the top
>>>>>>> left pad.
>>>>>>> 2. You get into the TTY promt by pressing *Ctrl+Alt+Next*.
>>>>>>> *Ctrl+Alt+Previous* is for exiting the promt.
>>>>>>> 3. The guide mentions first "cros-flash-replace" and then
>>>>>>> "cros-firmware-replace":
>>>>>>> "Then, the cros-flash-replace script has to be executed as such:
>>>>>>> # ./cros-firmware-replace flash.img coreboot ro-frid"
>>>>>>> By the way, shouldn't there be .img extensions after coreboot and 
>>>>>>> ro-frid?

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]