[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] T400 woes (2nd try)

From: romanis
Subject: Re: [Libreboot] T400 woes (2nd try)
Date: Mon, 6 Apr 2015 16:30:16 +0200

at last i have time to fiddle with my t400 again. On the weekend i spent
much time trying to get the g_dbgp module to work on my Galaxy S3,
unfortunately without much success.

Now i'm trying to get spkmodem to work. If i understood it correctly
i should connect the audio out jack of the t400 directly into the audio
in of the debugging host.

It may be a dumb question, but can i test it with headphones, or is it
possible that the headphones will be somehow damaged?



Gesendet: Samstag, 04. April 2015 um 02:42 Uhr
Von: "The Gluglug" <address@hidden>
An: "address@hidden" <address@hidden>
Betreff: [Libreboot] Fwd: Aw: Re: T400 woes (2nd try)
Hash: SHA1

please use "reply all", not "reply". it's better on the list, for peer

spkmodem is a way of debugging via audio cable. it uses a
line-in/line-out and a softmodem:

- -------- Forwarded Message --------
Subject: Aw: Re: [Libreboot] T400 woes (2nd try)
Date: Sat, 4 Apr 2015 01:36:14 +0200
From: Bella Riosa <address@hidden>
To: The Gluglug <address@hidden>

Not yet, but i'm working on using a android phone as a EHCI debugger.
What is spkmodem?

*Gesendet:* Freitag, 03. April 2015 um 15:47 Uhr
*Von:* "The Gluglug" <address@hidden>
*An:* "Bella Riosa" <address@hidden>, address@hidden
*Betreff:* Re: [Libreboot] T400 woes (2nd try)
Do you have a way to get debugging info from the coreboot log?
(EHCI Debug, spkmodem, etc)

On 01/04/15 21:01, Bella Riosa wrote:
> Hello,
> i tried to flash my T400 today with the latest released version
> (20150208) and the latest snapshot (20150401).
> Unfortunately it wasn't successful. Both versions had the same
> symptoms. The flashing went well, but the new BIOS didn't boot.
> The LCD screen was flickering a little bit on startup and then
> went black (with backlight on). An external Monitor attached to
> the VGA-Port didn't work either, saying some- thing about a wrong
> signal.
> After i reflashed the backup of the original BIOS everything
> worked again.
> i used the following command to flash the rom:
> # flashrom -p linux_spi:dev=/dev/spidev0.0,spispeed=512 -V -w \
> libreboot_bin/bin/x200_8mb/x200_8mb_usqwerty_vesafb.rom
> BTW, my programmer is a RaspPi.
> After the reflash of the backup i made several logs as suggested
> by fchmmr at IRC (many thanks for the help, btw)
> The original Bios version is 1.2 (7UET50WW) from 2008-10-03 The EC
> version is 1.01 and my CPU is a P8600. I'm using a samsung 2GB
> SODIMM (PC3-8500S-07-10-F2) but tried a faster one from Hynux, too
> (10600S-9-11-B2)
> I hope i didn't forget any critical infos.
Version: GnuPG v1


reply via email to

[Prev in Thread] Current Thread [Next in Thread]