[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] x200 wlan0 stays "Hard blocked"

From: Stephen Soltesz
Subject: Re: [Libreboot] x200 wlan0 stays "Hard blocked"
Date: Tue, 10 Mar 2015 01:38:43 -0400

So, maybe the silver lining of discovering I've asked a silly question
is finding an answer shortly after. There is a physical switch on the
left side of the case. Sorted.

Carry on! :-D

On Mon, Mar 9, 2015 at 10:26 PM, Stephen Soltesz
<address@hidden> wrote:
> Hi, all!
> I received my x200 last week from Francis and verified that everything
> worked, including wireless networking. Since I am accustomed to a US
> keyboard, I swapped my x200's UK keyboard for one with a US layout. I
> made a backup of the libreboot rom[1] and then flashed an updated
> libreboot rom[2] to default to the US keymap (and still boot the
> preinstalled OS).
> But, after these steps, I noticed that the wireless card[3] was stuck
> in a "hard blocked" state.
>     $ rfkill list all
>     0: phy0: Wireless LAN
>             Soft blocked: no
>             Hard blocked: yes
> The Fn+F5 keys on the x200 keyboard continues to toggle the Soft
> blocked state, but I cannot reset the Hard blocked state after reboot
> or any key combinations (apparently).
> So, I tried to restore the system to the its original state; I
> swapping the keyboards again back to the UK layout, and then reflashed
> the backup libreboot rom. Unfortunately, the wireless card is still in
> a "Hard blocked" state and unusable.
> From your experiences, does it sound possible that the steps I took
> have disabled the wireless card? Is there some initialization that
> libreboot performs after first boot that I may have accidentally wiped
> away? Is there a way to reenable the wireless card?
> If more information would be helpful, I'm happy to provide it.
> Thank you so much,
> Stephen
> [1]: flashrom -p internal -r libreboot.rom
> [2]: the binary builds from
>       bin/x200_8mb/x200_8mb_usqwerty_vesafb.rom
> [3]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
>   $ lshw  -C network
>   *-network DISABLED
>        description: Wireless interface
>        product: AR9285 Wireless Network Adapter (PCI-Express)
>        vendor: Qualcomm Atheros
>        physical id: 0
>        bus info: address@hidden:02:00.0
>        logical name: wlan0
>        version: 01
>        serial: 00:26:5e:4b:bd:3f
>        width: 64 bits
>        clock: 33MHz
>        capabilities: pm msi pciexpress bus_master cap_list ethernet
> physical wireless
>        configuration: broadcast=yes driver=ath9k
> driverversion=3.13.0-39-lowlatency firmware=N/A latency=0 link=no
> multicast=yes wireless=IEEE 802.11bgn
>        resources: irq:17 memory:e1500000-e150ffff
>     [... eth0 snipped ...]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]