[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] Bricked T60

From: Denis 'GNUtoo' Carikli
Subject: Re: [Libreboot] Bricked T60
Date: Tue, 17 Feb 2015 13:30:59 +0100

On Sun, 15 Feb 2015 23:57:14 +0100
Hadrien <address@hidden> wrote:

> Hello,
> I hope I am writing to the right ML.
> I tried to flash libreboot on a ThinkPad T60; however, I wanted to
> have SeaBIOS rather than GRUB2 as the main payload, so I built the
> ROM from sources with a modicum of hacking. Unfortunately, I somewhat
> botched the process, and after the first flash, I encountered many
> problems:
> 1. The LCD panel did not light up, and did not display any picture,
> yet it is compatible according to
> <>.
> 2. The VGA output was mostly garbage, though I managed to read some
> error messages.
>   a. SeaBIOS succeded in booting Linux.
>   b. Then the kernel complained about low memory errors.
>   c. Finally there was a kernel panic.
That's because the kernel linux detects some of your BIOS memory as
Passing it memory_corruption_check=0 and verify that
trough /proc/cmdline could have recovered it enough to flash something
if you were lucky enough not to have the computer lockup.

> Obviously I wanted to recover from this. Misinterpreting a remark on
> this website:
> <> ("If
> the laptop turns on, but doesn't boot at all; and there is absolutely
> no sounds or sign of life, Libreboot might have been flashed
> incorrectly. It is still possible to return to the Lenovo BIOS by
> disabling bucts 1"), I took the (wrong) decision to remove the CMOS
> battery (without having performed a second flash), and, as I now
> understand, I now have a corrupted ROM on the chip, with the last
> 64kb from the original BIOS and the rest from the new ROM. This
> brings about a bricking symptom: the laptop does not boot anymore and
> beeps three times (one long, two short).
Removing the power and the CMOS battery clears the BUCTS register.

> As the T60 is bricked, I tried to unbrick it with an external
> programmer, according to the instructions here:
> <>. My chip is a
> Macronix and I tried to wire the programmer as follows:
> 8765
> ----
> |  |
> ----
> 1234
> 1- CS
> 2- MISO
> 3- unwired
> 4- GND
> 5- MOSI
> 6- CLK
> 7- unwired
> 8- 3.3V
> But the chip is not very chatty:
>   flashrom -p buspirate_spi:dev=/dev/ttyUSB0 -r test.rom
> fails to detect the chip:
>   Found Generic flash chip "unknown SPI chip (RDID)" (0 kB, SPI).
> I attached the log with full verbosity. (the output is similar if I do
> not wire the 8th pin and plug the AC adapter to supply the board
> instead)
Flashrom mailing list might help on that too.

I'm not familiar with the buspirate(I don't have one). And the
buspirate is not simple: it has different firmwares that gives
different flashing speed, which are in turn handled differently by
flashrom. So I'm totally lost with that.

So first read what is on the flashrom wiki about the buspirate and mayb
e flashrom man has something on that too.

Take in account that you probably cleared the BUCTS register.


Attachment: pgpu9L0oKW6Iq.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]