[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot-dev] Toolchain error when building libreboot

From: xdrudis
Subject: Re: [Libreboot-dev] Toolchain error when building libreboot
Date: Sat, 30 Jan 2016 01:31:04 +0100
User-agent: Mutt/1.5.23 (2014-03-12)

On Fri, Jan 29, 2016 at 09:58:33PM +0100, Albin wrote:
> I did *almost* exactly the same, because I did upgrade GCC
> and maybe some other tool-chain packages on Wednesday. At first
> I thought this was the cause, but after I had tried with
> two other distros and gotten the same result and another user
> reported the same problem at the same time, then I thought that my
> upgrade couldn't have been the problem.

Having to compile the toolchain is more or less the usual case. 
Your old toolchain was ok for coreboot by chance, so you didn't
have to compile it until you upgraded your GCC. Then you tried it
in other systems where you hadn't tried it before and found the common
case that you have to compile your toolchain. 

makes sense ? 
> Maybe it was the case that the state in which my first system was on
> Tuesday just happened to be liked by coreboot while none of the others
> were. This could have been what's happened I suppose. Do you think so?

I would say yes. 

I'm not 100% positive, but it matches my experience. Not that I have
compiled coreboot in many different systems though, so maybe someone
knows better.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]