[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: failure on macOS

From: Mehul Sanghvi
Subject: Re: failure on macOS
Date: Sat, 4 Dec 2021 09:34:28 -0500

SHELL should be there in all environments.
Using “/usr/bin/env bash” is the correct way to find bash, or for that matter, any interpreter.

I had done work 5-6 years ago to get LE to work on MacOS but have since then lost the system I worked on to get that going.  It was a work laptop and had to give it back when I left the company.

Certain things don’t work because of differences between BSD and Linux/GNU tools.  I had tried to resolve those and submitted patches.

I’m not sure if those got accepted and were made part of a release.  

Sent from my "smart" phone

On Dec 4, 2021, at 08:11, Oleg Terentiev <> wrote:

Yes, it can be problem. For example, i have VM with Lubuntu 14.10 (2015y). There isn't variable BASH. Variable SHELL=/bin/bash but /bin/sh used default in terminal is link to dash (/bin/dash)
Just try to change it in any ansy-text editor.
To Community: may be change it in script? To /bin/bash (always predictable behavior) or /bin/sh (always exist) ?
04.12.2021, 19:20, "Paolo Redaelli" <>:

Il 04/12/21 12:26, Krishna ha scritto:

 Greetings all,

 Great to see activity on this list again! SE (through ELJ) was one of
 my favourite projects from the early 2000s.

 Tried installing the compiler on macOS and failed in
 bootstrap(). Does assume a Linux-like environment? is a bash script, finding the executable with the shabang
#!/usr/bin/env bash

My machines has GNU bash, version 5.1.8

MacOS ships with a completely outdated version of bash, 14 years old:

The issues could arise from this mismatch, but as I don't have access to
a MacOS machine I can't be sure.


b.r., Oleg Terentiev

reply via email to

[Prev in Thread] Current Thread [Next in Thread]