[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libcdio-devel] libcdio 0.83 release around Oct 27

From: Dagobert Michelsen
Subject: Re: [Libcdio-devel] libcdio 0.83 release around Oct 27
Date: Wed, 2 Nov 2011 20:27:37 +0100

Hi Rocky,

Am 27.10.2011 um 14:44 schrieb Rocky Bernstein:
>>> As with Thomas and his shameless plug, I will put in a plug for mine.
>>> I recently released a new version of remake.
>>> There is no Solaris package for it yet. Git sources for that if you
>>> don't want to get via
>>>  git clone git://
>>> is in ~/src/external-vcs/remake. I used those to build libcdio rather
>>> than gmake. It would be nice if that were a
>>> Solaris package.
>> I couldn't bootstrap from the git clone:
>>> unstable9s% autoreconf -fi
> I generally use the ./ script which adds a maintainer flag to
> configure. README.develop mentions

With the risk of looking stupid I neither can't find in the cloned 
nor README.develop and it is also not in the list of files here:
Obviously I am missing something...

In the meantime I have made a build from a contributed recipe from an OpenCSW
user (I mailed you separetely).

>>> Copying file ABOUT-NLS
>>> Copying file config/config.rpath
>>> /opt/csw/bin/gautopoint: : is not an identifier
> Probably some environment variable that is expected to be set but isn't.
> Just now did a git clone on login. Then switched to unstable10s to use the
> clone and had no problem running autoreconf -fi. I also tried using /bin/sh
> as my SHELL. A suggestion is to add set -x to  /opt/cws/bin/gautopoint, to
> see what it is running. Depending on the shell there are
> various settings of PS4 that give more and better information.
> bash:
> export PS4='-(${BASH_SOURCE}:${LINENO}): ${FUNCNAME[0]} -
> ksh for more modern ksh:
> PS4='(${.sh.file}:${LINENO}): ${} - [${.sh.subshell}]
> '
> zsh:
> PS4='(%x:%I): [%?] zsh+
> '
>> autoreconf: /opt/csw/bin/gautopoint failed with exit status: 1
>> Have you bootstrapped on the farm?
> I'm not sure exactly what you mean but I did build this on unstable10s.  The
> results are in
> ~rocky/src/external-vcs/libcdio.

Thanks, I'll have a look.

> A recently checked out git clone (which should be the same thing) is in
> ~rocky/src/build/libcdio
> If there is a nifty way to automate compiling across many architectures in
> the farm, I'd be interested and probably would have tried that.

The packaging system "GAR" can do that, but it is probably easier to just
fire off a couple of builds manually as the dirs are all NFS-mounted
across machines.

Best regards

  -- Dago

"You don't become great by trying to be great, you become great by wanting to 
do something,
and then doing it so hard that you become great in the process." - xkcd #896

reply via email to

[Prev in Thread] Current Thread [Next in Thread]