[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libcdio-devel] libcdio 0.83 release around Oct 27

From: Rocky Bernstein
Subject: Re: [Libcdio-devel] libcdio 0.83 release around Oct 27
Date: Thu, 27 Oct 2011 08:44:53 -0400

On Thu, Oct 27, 2011 at 7:20 AM, Dagobert Michelsen <address@hidden> wrote:

> Hi Rocky,
> sorry for the late reply, feel free to ping me as I sometimes loose track
> and background activities...
> Am 20.10.2011 um 18:03 schrieb Rocky Bernstein:
> > I've compiled this on current10s. Would have tried on a 64-bit machine
> > as well, but I wasn't sure what that would
> > be called.
> >
> > In the past I asked for a real CD or DVD drive with various kinds of
> > media (audio CD, data CD with an ISO-9660
> > filesystem)  to be attached for libcdio testing. I didn't want to
> > bother you, but if you don't mind if you could attach
> > devices and let me know privately where those are attached that'd help.
> I hope to get back next week to set up something. As I said feel free to
> ping
> me and I promise not to be bothered :-)
> > But since this is all remote, even better would be if you could build
> > and run "make test" on a physical box where
> > you can eject drives and put in CD's and see that things work, that'd
> > be even better.
> I have massive problems building this. How did you build it on Solaris?
> With Sun Studio or GCC?


> > As with Thomas and his shameless plug, I will put in a plug for mine.
> > I recently released a new version of remake.
> > There is no Solaris package for it yet. Git sources for that if you
> > don't want to get via
> >   git clone git://
> >
> > is in ~/src/external-vcs/remake. I used those to build libcdio rather
> > than gmake. It would be nice if that were a
> > Solaris package.
> I couldn't bootstrap from the git clone:
> > unstable9s% autoreconf -fi

I generally use the ./ script which adds a maintainer flag to
configure. README.develop mentions

> > Copying file ABOUT-NLS
> > Copying file config/config.rpath
> > /opt/csw/bin/gautopoint: : is not an identifier

Probably some environment variable that is expected to be set but isn't.

Just now did a git clone on login. Then switched to unstable10s to use the
clone and had no problem running autoreconf -fi. I also tried using /bin/sh
as my SHELL. A suggestion is to add set -x to  /opt/cws/bin/gautopoint, to
see what it is running. Depending on the shell there are
various settings of PS4 that give more and better information.

export PS4='-(${BASH_SOURCE}:${LINENO}): ${FUNCNAME[0]} -

ksh for more modern ksh:
PS4='(${.sh.file}:${LINENO}): ${} - [${.sh.subshell}]
PS4='(%x:%I): [%?] zsh+

> autoreconf: /opt/csw/bin/gautopoint failed with exit status: 1
> Have you bootstrapped on the farm?

I'm not sure exactly what you mean but I did build this on unstable10s.  The
results are in

A recently checked out git clone (which should be the same thing) is in

If there is a nifty way to automate compiling across many architectures in
the farm, I'd be interested and probably would have tried that.

> Best regards
>  -- Dago
> --
> "You don't become great by trying to be great, you become great by wanting
> to do something,
> and then doing it so hard that you become great in the process." - xkcd
> #896

reply via email to

[Prev in Thread] Current Thread [Next in Thread]